Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Kia Sportage LX 2012
Joined
·
2 Posts
Discussion Starter #1
Hi to anybody out there, I have a problem, working on this 2012 Kia Sportage lx 2.4 engine. originally the car ran hot and the guy that owns it took back to dealer and dealer couldn't find problem sent car home and kept running hot dealer still couldn't find problem thought guy was telling a lie. Car ran hot so guy drove car to dealer by time he got there the car was hot to the point it blowed head gasket. car still under warranty but dealer wouldn't make it right because guy run car to hot. dealer was going to rebuild the car at an outrageous price. They tore the engine down and kept the car for several months and still didn't do anything to the car. So guy goes to dealer and says I want my car now, so dealer put all engine and engine parts in a box and the guy takes car home like that. He hires my partner to rebuild the engine, we take block and head and gets it resurfaced put all new parts except oil pump, (New Balance shaft oil pump is like close to 800.00dollars) so we didn't put new balance shaft oil pump in. Just cleaned original one up but we did use the new chain, guide and tensioner. car was running great when we put it back together all obd codes had reset and the chain to the balance shaft oil pump broke. does anyone out there have any idea why a new chain would break? Would appreciate any suggestions. Thanks in advance
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
9,882 Posts
we didn't put new balance shaft oil pump in. Just cleaned original one up but we did use the new chain, guide and tensioner. car was running great when we put it back together all obd codes had reset and the chain to the balance shaft oil pump broke. does anyone out there have any idea why a new chain would break?
Could be a good number of reasons, but my first thoughts would be wrong or inferior parts, or incorrect installation.
 

·
Registered
Joined
·
1 Posts
Did you ever figure out what caused the oil pump chain to fail? Having my engine rebuilt and was thinking of using the same oil pump/balance shaft with new chain & tensioners
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
9,882 Posts
Did you ever figure out what caused the oil pump chain to fail? Having my engine rebuilt and was thinking of using the same oil pump/balance shaft with new chain & tensioners
Using the below link, please add location and vehicle (year & model) to your User Account/Profile

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD




https://www.kia-forums.com/threads/forum-rules.27240/


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 
1 - 4 of 4 Posts
Top