Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
OK, for the last few months, my 08 Kia Rio has been stuck in "limp" mode. The engine revs freely, but the car won't go over about 25 MPH. I took it to the dealer who charged me $110 to tell me the front catalytic converter was bad. I changed it myself. Problem not fixed. I am ready to change the front & rear O2 sensors and the other catalytic converter, but need to know if the sensors are the same or different from each other.

And, more to the point, will this fix my problem? I am unfamiliar with the limp mode, and have only heard about it second hand in the past. The guy at the dealership told me that the car went into limp mode which is only supposed to give you enough power to pull over and perhaps get into a parking lot, so you can get it towed to the dealership where they can get lots of your money to fix it.

I know what I'm doing around a set of metric sockets, so I can fix most of the stuff myself, but I need to know if these replacements will do the trick.

Any opinions out there?

Anybody?

Bueller?

Anybody?

-Ralphie
 

·
Registered
kia rio5
Joined
·
27 Posts
I would go with replacing your other cat. Your other cat could be partly plugged which is why you're only going 25mph. When both of mine went I couldn't get my car to go passed 2000rpms without stalling. If I remember correctly both o2 sensors are the same. Another thing you could do is Replace your spark plugs if you haven't already done that. I know my plugs in my 07 1/2 rio5 fail about every 60,000kms
 
1 - 2 of 2 Posts
Top