Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi All, i'm new on here and have owned 2003 xs auto crdi for several months. It has been raining really hard for the last week or so and my car has no response form the gas pedal and is idling at 1200rpm. Once warmed up it the revs up on it's own intermitantly still with no response from th gas pedal. the engine management light is on and the OD light is flashing also. has anyone experienced this or has any idea's where to start getting this fault rectified? Any advice will be welcomed. Many thanks, John.:(:(
 

·
Registered
I now drive a 2003 S-10 Had an 03 LX 3.5 Sorento
Joined
·
2,475 Posts
:00000732:to the forum.

Get the codes read and let us know what they are. Its like going to the doctor and telling him you don't feel well and he doesn't have your lab results. He would only be guessing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
codes today was 00002 and 00004 canbus error. auto elec rekons fault in the loom and is back tomorrow with wiring diagram..... when plugged in the throttle was regestering on his machine.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Just to update you all.....

the car has a leek possibly sunroof or windscreen, i have read post on here about this before. anyway water is dripping down the driverside pillar and in to the footwell. Water has worked it's way in to the fuse box in the drivers side footwell and has started to corrode the board. it has been sraped and cleaned and also has a silicon spray to prolong it's life. once all put together and codes cleared (U0004 and U0002 High speed Can error + side low) the car came back to life. Throttle works, revs normal, flashing OD gone.

I have been advised to fix the leak and replace the internal fuse box.
Has anyone got any ideas where i could find and internal fuse box? i just looked on ebay and couldnt find one.

Thanks


Read more: UK Kia Sorento Forum - Login
 
1 - 4 of 4 Posts
Top