Kia Forum banner
1 - 14 of 14 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Recently, I started having strange problems with my 2003 Kia Sorento. After starting the engine (when cold), I push the accelerator pedal but there is no response (keeps idling or not more than 1300 rpm..it depends). Moreover, idling is irregular and I don't have any error codes. After restart, everything comes back to normal. What do you think about this? Any ideas? :confused:
 

· Registered
2006 Kia Sorento 3.5 5sp Auto
Joined
·
267 Posts
I am no expert, so don't take this as solid advice.
But sounds like a possibility of one of the sensors (either crank or camshaft sensor) being a little dodgy...
The rough idling makes me think that more than anything else.

(forgot which sensor it is, but seem that on some cars they last about 100000km. (my sisters vectra had it and the previous owner of my sorento had it just before i purchased it. i saw the receipt in the car)
 

· Registered
Joined
·
1 Posts
Idle and acceleration problem

Good day
I am new to this so please bear with me. I have a Kia Picanto 2005 LX that I have had from new. Yhe motor has done 240 000 odd km's. Recently the car has started acting like she has a flat spot. Someone suggested I change the spark plug leads which I duly did and it seemed to ease the problem. As of today the flat spot has gotten progressively worse. When accelerating from idle the car has this flat spot but once past two thousand RPM it seems to stabilise. However I called the mechanic back now as now whilst idling it is hunting and the idle is irratic. Both mechanics that came are dumbfounded as am I.

Please help me. I am my wits end. This car has never given me a day of hassle till now.

I would appreciate any help as tot he cause of this problem
 

· Registered
05 Kia Sorento LX 4x4
Joined
·
279 Posts
Good day
I am new to this so please bear with me. I have a Kia Picanto 2005 LX that I have had from new. Yhe motor has done 240 000 odd km's. Recently the car has started acting like she has a flat spot. Someone suggested I change the spark plug leads which I duly did and it seemed to ease the problem. As of today the flat spot has gotten progressively worse. When accelerating from idle the car has this flat spot but once past two thousand RPM it seems to stabilise. However I called the mechanic back now as now whilst idling it is hunting and the idle is irratic. Both mechanics that came are dumbfounded as am I.

Please help me. I am my wits end. This car has never given me a day of hassle till now.

I would appreciate any help as tot he cause of this problem

This part of the forum is for the Kia Sorento SUV. A quick search tells me the Kia Picanto is a sub-compact. You would be best served by posting in the part of the forum for the Kia Picanto (Kia Morning, Kia New Morning, Kia Euro Star (Taiwan), Naza Suria (Malaysia), Naza Picanto (Malaysia)).

http://www.kia-forums.com/kia-picanto-forum/
 

· Registered
Joined
·
2 Posts
Im having something similar with my 2006 lx which has also giving me no bother til now. Im bringing mine to mechanic today n will let u know what he says but mine is worrying me as this lack of accelerating only happened after he replaced my brake caliper :(
 

· Registered
2003 Kia Sorento EX 4x4
Joined
·
7 Posts
Thats where I would start. Don't just replace but test it first.
I have a 2003 Kia Sorento EX 3.5L 6 Cyl DOHC 4x4 with 96k miles and I just financed it on 4/1/14. The vehicle has randomly died on me 3 -5 times while driving. The first time was when the vehicle was cold and it died once at a stop sign (took 3 tries to start again) and about a mile from there after almost coming to and attempting to accelerate onto the interstate ramp. I was stepping on the gas pedal and nothing was happening at all, while the rest of the car seemed to be working fine (lights, stereo, ) I had to pull over and put the car in park to start it.

The vehicle is idling rough so my first thought to that was I need to tune up with spark plugs and wires which is first on my list.

There is no check engine or service lights lit on the dash.

I do not believe this would be due to spark/wires being bad but I could be wrong.

I believe this could be due to a sensor issue as you said nstoolman1. If it were the Throttle Position Sensor, you mention to check it. How would I do that?
(I am 26 years old and try to understand how to fix my own vehicles the best I can. I do not really have anyone around me to show me though. )


Do you have any other ideas of what I can check?

Thanks so much for everyone's help!
 

· Registered
I now drive a 2020 Ram Bighorn. Had an 03 LX 3.5 Sorento
Joined
·
2,529 Posts
I have a 2003 Kia Sorento EX 3.5L 6 Cyl DOHC 4x4 with 96k miles and I just financed it on 4/1/14. The vehicle has randomly died on me 3 -5 times while driving. The first time was when the vehicle was cold and it died once at a stop sign (took 3 tries to start again) and about a mile from there after almost coming to and attempting to accelerate onto the interstate ramp. I was stepping on the gas pedal and nothing was happening at all, while the rest of the car seemed to be working fine (lights, stereo, ) I had to pull over and put the car in park to start it.

The vehicle is idling rough so my first thought to that was I need to tune up with spark plugs and wires which is first on my list.

There is no check engine or service lights lit on the dash.

I do not believe this would be due to spark/wires being bad but I could be wrong.

I believe this could be due to a sensor issue as you said nstoolman1. If it were the Throttle Position Sensor, you mention to check it. How would I do that?
(I am 26 years old and try to understand how to fix my own vehicles the best I can. I do not really have anyone around me to show me though. )


Do you have any other ideas of what I can check?

Thanks so much for everyone's help!
Go here and sign up. Then look your vehicle up and look for the TPS. There should be a procedure on replacement and adjustment.

http://www.kiatechinfo.com/
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top