Kia Forum banner
1 - 3 of 3 Posts

· Registered
2003 Kia Rio
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello everyone. Thanks in advance for your help.

I took my car to get inspected, and it failed because the O2 and EVAP systems are reading as "not ready". I was told to drive the car around for a while and come back.

I drove for a few days, about 100 miles. Went back today and the same two systems are reading as "not ready". They hooked up a diagnostic tool to the onboard computer and told me that there are no codes stored in the computer.

I am very confused as to what is going on.

Is there any way to get the computer to reset? I've read about clearing the codes, but there are no codes to clear. Would unhooking the battery work? The car won't pass inspection as long as those two things are reading as "not ready".
 

· Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,022 Posts
Pull the negative terminal off the battery for 10 minutes to try to reset the ecu and drive it around again maybe it will help. Reguards ronjohn
 

· Registered
Joined
·
226 Posts
Find a competent technician who can analyze the readiness monitor test data to try and discover why those two tests will not pass. I have seen a few instances where for example, an oxygen sensor's readings are just under the threshold to pass the test but do not meet the criteria to set a trouble code. Has the catalyst monitor run and is complete? You should only need one more test to pass inspection if NY is like the states that I am familiar with.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top