Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
i have a 2001 sephia, i had 6 error codes,p0301 p0342 p0705 p0758 p1614 and p1624. i replaced the injector so that eliminates 0301, my question is what do i do about the other 5 codes???? help!!!!
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,928 Posts
With all of the codes you posted ...I would be looking for a bunch of bad wiring harness (and ground) connections caused by corrosion.

(P0342) Check the wiring around the cam position sensor and the ground wires around it.

(P0705, P1614 and P1624) I would also replace the transmission range selector switch see..
http://www.kia-forums.com/2g-1998-20...automatic.html

(P0758) P0758 implies solenoid "B"
Again ...look for bad connections...
That may solve quite a few transmission related problems...

Early Spectras/Sephias had loads of corrosion problems and most of yours probably is just that.

Dave
 

·
Registered
sephia LS 2001
Joined
·
7 Posts
I had the same problem with a 2001 Sephia.Kia replaced the computer and tranny but codes kept appearing. Eventually a new alternator solved the stress. This was back in 2004.

Today I found out that a bad battery connection was causing the no-start and spedometer problems

Good luck with your codes


Alan
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,928 Posts
Sounds like a good idea... Was the alternator putting out too low voltage?
Thanks for your feedback to the forum members.
Dave
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,121 Posts
1 code could cause 4 others to come on. But with only 1 issue. Example, my sephia when we first put a cai on it, we broke the iat wire. Car started doing all sorts of bad things, stall, bad idle, no power. scanned it, got 6 or so codes. Low and behold, replaced iat wire, all 6 or so codes were cleared after reset.

Look at each one, could be as small as my issue was but got multiple codes. With needing only 1 fix.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
chaneged injector and regulator...for a while the car rode fine with no ce light now when im approaching stops the car begins to jerk and cut off after sitting for a few minutes it starts up and drives but its still jumpy;after sitting overnight it drives fine until on the way home in the afternoon...im at a complete loss as to where to start; my husband is pretty handy and can handle most diy but we just dont know whats going on here. can anyone help? we dont know where the cam pos sens is located or the trans range thingy....please help
 
1 - 6 of 6 Posts
Top