Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I am new here and hoping to get some information. My nieghbor has a 2001 Kia Optima, 4 cylinder. He bought it about 6 months ago and had nothing but trouble. Without going down the list, here's my question.

1. Check engine light came on, hooked up the scanner and it read a crankshaft sensor, replaced it (which was NOT fun), car ran like a champ......going down the interstate the other day the car quit, he had it towed, I hooked up the scanner and low and behold its showing a crankshaft sensor. I know there's the possibility of buying a bad sensor, luckily its a lifetime replacement but not looking forward to changing it out. Are there 2 crankhaft sensors by any chance?

2. The connector for the camshaft sensor was taped, dummy me pulled the tape off to check connection there and the 3 wires came out, have no clue what order these wires go, looks like 2 black and one orange...can anyone help me out???


Any and all info greatly appreciated!
 

·
Registered
07 Optima 2.4L
Joined
·
109 Posts
Hi..If you, or any others, haven't done so already, it is always a good idea to first check onlineat the useful Kia Tech website for the latest TSB info and service details for your specific model car and VIN. (www.kiatechinfo.com).

Register first, using Internet Explorer for best results, and be sure to download Adobe SVG player on the links to access the TSB info, as well as the SERVICE info, going to SHOP (expanded parts) and ETM (expanded wiring diagrams) DTC (codes) and COMPONENTS (R and R info). You can easily access and print out everything you need right there.
 
1 - 2 of 2 Posts
Top