Kia Forum banner
1 - 9 of 9 Posts

·
Registered
2012 Sorento SX V6 2WD Titanium/B&D leather
Joined
·
309 Posts
Discussion Starter · #1 ·
Latest TSB info
 

Attachments

·
Registered
Sorento EX V6 Lux, 1992 Nissan Maxima VE5, 2011 Ducati Monster 796
Joined
·
39 Posts
Thanks for this! I just had my nav unit changed last week, and now it looks like an old VHS: flickers, colour cuts in and out...

Now I have to go back to the dealer again, with this in hand. Sometimes I feel like I'm doing their work for them!

Anyone know if the firmware can be updated or just the map software? If not, then it looks like they have to replace the Nav unit again.
 

·
Registered
Sorento EX V6 Lux, 1992 Nissan Maxima VE5, 2011 Ducati Monster 796
Joined
·
39 Posts
what is this TSB for? I have 2012 model and my nav/backup camera are working just fine
It's only for if they need to replace the Nav unit for some reason, typically "internal failure". This TSB specifies the proper version/part numbers the dealer needs to order depending on manufacture date of your vehicle.

If you have no issues, then you don't need this.
 

·
Registered
2012 Sorento SX V6 2WD Titanium/B&D leather
Joined
·
309 Posts
Discussion Starter · #5 · (Edited)
Thanks for this! I just had my nav unit changed last week, and now it looks like an old VHS: flickers, colour cuts in and out...

Now I have to go back to the dealer again, with this in hand. Sometimes I feel like I'm doing their work for them!

Anyone know if the firmware can be updated or just the map software? If not, then it looks like they have to replace the Nav unit again.
It is not your dealer's fault...this TSB just came out yesterday.If you are having problems with the older OEM version head unit (if,in fact, that is what the dealer did)...they will access the new TSB and remedy. As to the other poster, I post these TSB's the same day they come out to notify those it effects.:)
 

·
Registered
Sorento EX V6 Lux, 1992 Nissan Maxima VE5, 2011 Ducati Monster 796
Joined
·
39 Posts
It is not your dealer's fault...this TSB just came out yesterday.If you are having problems with the older OEM version head unit (if,in fact, that is what the dealer did)...they will access the new TSB and remedy. As to the other poster, I post these TSB's the same day they come out to notify those it effects.:)
I don't blame them for the TSB, but I do for not doing QA on their work. Seeing that the replaced head unit had some issues after installation should raise some bells that something is not right. You can clearly see as soon as you put the car in reverse that something is wrong with the video display. I've been back to the dealer 8 times for different minor issues with the car, so my patience is starting to run a little thin.

Appreciate you posting the TSB. I spoke with the dealer about it, and a new unit is on order.
 

·
Registered
10 Optima LX, 12 Sedona LX
Joined
·
1,413 Posts
I don't blame them for the TSB, but I do for not doing QA on their work. Seeing that the replaced head unit had some issues after installation should raise some bells that something is not right. You can clearly see as soon as you put the car in reverse that something is wrong with the video display. I've been back to the dealer 8 times for different minor issues with the car, so my patience is starting to run a little thin.

Appreciate you posting the TSB. I spoke with the dealer about it, and a new unit is on order.
Usually if the picture flickers or has snow or static it is a bad camera, and it is usually intermittent, so it may not have been doing it at the dealer. If it does it again, leave it in reverse and firmly apply the parking brake, get out and bump the camera on the lift gate. If the picture clears up, its not the head unit, but the camera that's at fault.
 

·
Registered
2011 Titanium Sorento SX - 39,000 miles since 03/2011
Joined
·
106 Posts
My backup cam stopped working intermittently, and then almost permanently and they replaced it without a problem. My dealership has been pretty good with these kind of things.
 

·
Registered
2011 Sorento AWD V6 SX Cherry Black
Joined
·
231 Posts
Same here. First vehicle failure in 18,000+ miles. Dealer changed it and washed the car within 1 hr at of course no cost to me. So far very happy camper.
 
1 - 9 of 9 Posts
Top