Kia Forum banner

1 - 9 of 9 Posts

·
Registered
06 Kia Sorento 12 Kia Soul 03 Kia Rio (traded in 2009)
Joined
·
5 Posts
Discussion Starter #1
I know this has been posted other times but my problem seems to be a bit different. I have a 2006 Sorento, installed a new after market JVC stereo. Now I am having dash light problems. But here is the twist, the car came new with a remote start, when I use the remote start the dash lights come on until I put the key in and turn the car to run, then the radio comes on and dash lights go out.

To me this sounds like the circuit may be overloaded but I am not sure and if that is the case how do I resolve this.

Thanks for any suggestions.
 

·
Registered
05 Kia Sorento LX 4x4
Joined
·
280 Posts
I know this has been posted other times but my problem seems to be a bit different. I have a 2006 Sorento, installed a new after market JVC stereo. Now I am having dash light problems. But here is the twist, the car came new with a remote start, when I use the remote start the dash lights come on until I put the key in and turn the car to run, then the radio comes on and dash lights go out.

To me this sounds like the circuit may be overloaded but I am not sure and if that is the case how do I resolve this.

Thanks for any suggestions.
Take it out, and verify the orange and orange/white wires are wired correctly. Sounds like its shorting out the "illum" wire. The aftermarket radios constantly poll the illum wire to see if it needs to be bright or dim setting. You can safely disconnect the illum wire to test.
 

·
Registered
06 Kia Sorento 12 Kia Soul 03 Kia Rio (traded in 2009)
Joined
·
5 Posts
Discussion Starter #3
There is no orange wire on the radio so I have the one from the wiring harness taped off. I checked the orange white and even disconnected it but still no luck.
 

·
Registered
05 Kia Sorento LX 4x4
Joined
·
280 Posts
This only happens if you've used the remote starter? What happens if you don't remote start it?

It could be that the remote starter has the parking lights on a separate, parallel, circuit from the "normal" light circuits. My parking lights are on with the aftermarket starter I have, and when I get in (and my regular lights are "off", than the dash lights cut out). I'm wondering if this is normal behavior.
 

·
Registered
06 Kia Sorento 12 Kia Soul 03 Kia Rio (traded in 2009)
Joined
·
5 Posts
Discussion Starter #5
If I start the car normally (no remote start) I never have dash lights. As soon as the ignition switch turns to the on position they go out.
 

·
Registered
2004 kia sorento 3.5 v6 gas
Joined
·
78 Posts
You might try posting your question on the12volt.com There are a lot of installers that are very helpful on the forum. Good luck.
 

·
Registered
06 Kia Sorento 12 Kia Soul 03 Kia Rio (traded in 2009)
Joined
·
5 Posts
Discussion Starter #8
Well after trying all kinds of things I turned to a pro. Found out that there is an additional fuse under the hood (not just the three inside). That fuse was blown. Replaced it and all is well

thanks for all your suggestions.
 

·
Registered
05 Kia Sorento LX 4x4
Joined
·
280 Posts
Well, we certainly appreciate you stopping back to let us know what you found out! Very weird IMHO. Which fuse was blown that only affected the lights aside from when the remote starter was used?
 
1 - 9 of 9 Posts
Top