Kia Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Im trying to help my friend out, i changed the plugs and air filter, along with plug wires. I disconnected the battery in the process of doing this and now it wont start. It will crank and crank but no start. its getting fuel, but apperntly no spark. Any help appreciated.
 

·
Premium Member
2020 Hyundai Palisades
Joined
·
2,970 Posts
i would check the electrical connectors as possibly one was disturbed when changing the plugs and have you checked the fuses.
 

·
Registered
Joined
·
17 Posts
which electrical connectors are you referring to? I just change spark plugs and wires and to that had to take apart 1/2 the engine. I am have same issue with cranking but no turn over.
 

·
Registered
Joined
·
17 Posts
I was thinking same thing as most easy thing to goof. usually when changing l just swap one wire at a time to avoid the confusion. however, it took a really long time as the boot broke off on number 1 (top left plug when viewing from front of engine). so maybe in frustration I did goof. Are there any tell tale signs? how can tell if firing at all? bad wires? what should i be looking for to diagnose? any sensors i might have not hooked up or damaged? i saw some thread pointing toward the mass flow sensor, another toward oxygen sensor and yet another mentioning lack of any spark.........any help is appreciated.

just so on same page -when viewing from grill toward passenger cabin

firewall of car
1 3 5
2 4 6
Front of car



https://www.google.com/search?q=kia+amanti+2004+spark+plug+wiring&newwindow=1&espv=2&biw=1920&bih=947&tbm=isch&imgil=Oe2OCDpiaQ3liM%253A%253B1-X0zlvtn-jmLM%253Bhttp%25253A%25252F%25252Fwww.justanswer.com%25252Fkia%25252F53ki5-kia-amanti-firing-order-wire-order.html&source=iu&pf=m&fir=Oe2OCDpiaQ3liM%253A%252C1-X0zlvtn-jmLM%252C_&usg=__tV-yvdNXjhkMHLeV1w4EkNeYZEQ%3D&ved=0CEoQyjc&ei=gx2QVe_WDYHloATH0YP4BA#imgrc=ey4h8OW5XyfhQM%3A&usg=__tV-yvdNXjhkMHLeV1w4EkNeYZEQ%3D


Verified wired correctly. 1-4, 3-6, 5-2


While tryng to turn over I pull back the spark plug wires from 2 4 or 6 (these are on the front and easy to access, 1 3 5 are buried under maniforld) not getting any spark or clicking.

Any ideas. Crankshaft sensor? O2 Sensor? ?? ??
 

·
Registered
Joined
·
17 Posts
Another item to add to the mix: security engine lock out???

When I turn the key from 'on' (Dash lights- battery , security, p for park, oil, and check engine) to start the battery and security lights stay illuminated. It is a new battery that I just recharged as I ran down trying to resolve this crank no start issue so battery not a concern but the security light??? What does an engine with a security trip sound like at start up?
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,928 Posts
I "see" you are in California and for the most part the "immobilizer" circuitry was not used in the USA...
It does sound like you have this "security" device... Where did the car come from? Canada?
It's possible that the KIA "luxury" cars might have it installed...
Check with a KIA dealer..
Also do a search for "Amanti immobilizer" on Google...

Usually the immobilizer light will flash a code when the ignition is turned to the "ON" position...
Dave
 

·
Registered
Joined
·
17 Posts
Purchased in Massachusetts. It was marketed as a luxury car - has all the bells and whistles of much higher priced car.

When going from 'on' to 'start', If the 'car with key' immobilizer icon remains illuminated even after check engine light goes out is that indicative of a bad immobilizer, bad key, reprogramming......what is solution?

since going down this security angle - the 10 amp fuse under dash labeled b/alarm is not active. I probed the fuse slot with a test light and could not get anything. do you know what I have to to turn on (or off) to get this fuse to respond. for example, the rear tail lights fuses are not hot until you turn on the lights.
 

·
Registered
2005 Kia Amanti
Joined
·
21 Posts
I've had similar issues when unhooking my battery and it was a very simple fix, assuming you have a key fob for the car....with the key fob just lock, unlock, lock, unlock get in and should start right up. As someone else had stated it seems to be a security issue which should resolve itself as soon as the unlock signal is verified. With an Amanti slightly older than my own, and perhaps no fob is available, try the same lock sequence with the key in the door. Good luck!
 

·
Registered
Joined
·
17 Posts
It turned out to the ignition failure sensor.

Ok part 27370 38000, the ignition fail sensor, arrived today. I installed it and started up but was running very rough. The code reader indicated ignition coil failure and throttle valve sensor issues

While car was running I pulled back the spark plug wire (connecting spark plug 1 and the coil on top of spark plug 4) and there was no sparking. I tried same with other wires and coils and there was sparking. I rotated the coils just to see if coil was bad and once again when pulled back the wire connecting to 1 there was no sparking. I changed spark plug 4 and tried again. Once again no sparking. I checked all the fuses and no bad fuses. I checked the wire harness to coil 4 and it responded the same as coil 6 - left most terminal was hot with 12v light tester.

Picture attached is the the wire harness leading into all the coils.

I checked the throttle valve sensor and it did not feel bound up - I did not hook it up to any diagnostic equipment as thought the ignition failure probably caused the the throttle code. I hope I put it back correctly.

Any idea what is is causing the 1/4 mis fire? Could the new sensor be faulty?
 

·
Registered
Joined
·
17 Posts
while trying to sort out the mis fire on middle coil (cyl 1-4)
the ignition system has gone completeley dead.

when looking at coil wiring or ignition failure sensor - how can tell which end to start counting from ie is '1' from wiring diagram the red wire on the coils in picture? is '1' on IFS the green in picture?
 

Attachments

1 - 17 of 17 Posts
Top