Kia Forum banner

1 - 6 of 6 Posts

·
Registered
02 Optima 2.4
Joined
·
6 Posts
Discussion Starter #1
I have a 2002 Optima SE 2.4L and I am trying to test my Closed Canister Valve circuit and the rest of my EVAC system to get rid of P0446 code. Working with the steps in Kiatechinfo it looks like one side of the CCV is +B from the ECM Control Relay and the other side is pulled low by the ECM to energize the CCV. I verified that when the CCV is connected and the engine is idiling, I have voltage at both of the terminals to gnd. When I short the white wire to gnd. (which I believe is the wire that goes to the ECM) I can hear the valve energize but normally it never seems to energize at all. I am wondering if I have an open on the white wire to the ECM but cannot seem to figure out the wiring by lookin at the 4 connectors going into my ECM. It doesn't match anything I see in the schematics on Kiatechinfo. My connectors look like they have three rows of wires each. Does anyone know where else I could look or explain better the pinout of my ECM. I also tried searching this forum too but couldn't find anything. I attached a pic of what I'm lookin at. Thanks in advance.
 

Attachments

·
Registered
02 Optima 2.4
Joined
·
6 Posts
Discussion Starter #2
I found it....I was looking at the section ENGINE CONTROL SYSTEM. When I looked at ENGINE/TRANSAXLE CONTROL SYSTEM then I found my ECM with the connectors that have 3 rows each.
The connection WAS good from my CCV to the ECM. I just didn't wait long enough to see it energize. I ended up just knocking out as much dried mud and dirt that I coulld from the filter that's attached to the CCV and reset the codes. So far so good. Hope that's all it was.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,866 Posts
I just looked up the wiring and it goes to a 12 pin connector on the ECM. The wire is white. The ECM does pull one side of the CCV connector to ground.
So you probably had a bad connection from the harness to the CCV valve on the white wire.
Dave
 

·
Registered
02 Optima 2.4
Joined
·
6 Posts
Discussion Starter #4
Thanks for the reply Dave. That's what got me confused cause I don't have a 12 pin connector on my ECM.
There's another set of schematics on the same list at Kiatechinfo that's for an ECM/TCM and it shows the connectors that I have. Not sure why there's two different sets of drawings for the Optima(MS)[2001-2006] / 2002 G 2.4 DOHC ???
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,866 Posts
I know the 2.4L and the 2.7L V6 models have different wiring harnesses and kiatechinfo may not publish both circuits... There is a thread on Hyundai-forums.com (that I frequent) about swapping these two engines in the 1998~2005 Sonatas (Optima's cousin)section from a poster named "elvis" on this..
My daughter has an 04 Sonata I rebuilt from salvage and have found answers there that have applied to Optimas here..
Dave
 
1 - 6 of 6 Posts
Top