Kia Forum banner

1 - 5 of 5 Posts

·
Registered
2013 Rio SX Nav Silver/Black
Joined
·
68 Posts
Discussion Starter · #1 · (Edited)
Ok So I have had my SX for about 5 months now and I am starting to get frustrated with the navigation system.

1. when I have USB stick connected it shows titles, folders, etc. YAY

2. when I have Apple device connect it shows.. Well WFCG.MP3 or what ever it thinks its playing.. I can can control the device and all but can not see the name of the song.. just random folders and letters for the name. ( I have tried Iphone, Ipod(s) all the same)

3. Slow.. Its slow some times, the display lags from time to time when switching between, Media, Sat, FM, CD, or even reverse..
going from FM to SAT the audio will switch but the screen will lag for 15-30 sec then switch over.
Or even going into reverse for the cam, I can start the car sit for 10-20 sec getting myself all organized with the car running, put it into reverse back out of my stall and drive before the cam even comes on all I get when Im finally moving forward is a black screen with a flash of the guide lines and then back to the normal screen..

This is not ALL the time but happens more than not.. some days its playing nice, other days.. not so much..

I have only reset the NAV once, (did not like having to set up all my stations again)

Anyone else having this problem or know of a fix or what could be causing it..
I have always have had NAV in my cars and this one seems just to be moody..

Maybe I should not have given it a girls name.. :confused:
 

·
Registered
hyundai Tucson
Joined
·
4 Posts
Did you try updating the firmware?, my friend have a problem with the backseat speakers when he turns on the "surround" they almost get mute, so he take his car to the service and they update the radio firmware and the problem disappear till now.

Good luck =D
 

·
Registered
2013 Rio SX Nav Silver/Black
Joined
·
68 Posts
Discussion Starter · #5 ·
I have tried an iPhone 4, 4S and 5 all have the same issue, as well as 3 different generations of iPods.

Any apple devices really dont seem to play well with my nav..

I was not aware there was a firmware update available as of yet, I seen the one for the Sedan with manual tranny..

Any Map Updates yet?
 
1 - 5 of 5 Posts
Top