Kia Forum banner

1 - 14 of 14 Posts

·
Registered
Sorento KX4
Joined
·
400 Posts
Discussion Starter #1 (Edited)
just had a call from the new buyer to say our sportage has developed a fault
ABS light on
ESP
4 wheel drive lock
hill decent
traction control and very heavy steering
in the garage for brake switch but this has not worked anyone else had this problem ?
 

·
Registered
Sportage 2.0 EX
Joined
·
41 Posts
Could be an electrical problem. Electrical power steering and other systems could go out if the voltage is too high or too low. Have they checked the battery / alternator? Had something similar happen to my previous car and it turned out the alternator was overcharging (16 volts when engine was on).
 

·
Registered
06 Sedona LX, 06 Sedona EX, 14 Forte EX, 11 Sportage EX, 11 Forte 5-door SX, 15 K900 VIP+
Joined
·
1,143 Posts
Sounds to me like an alternator fault. When the regulator in the alternator went in each of my Sedonas, they both illuminated ABS, ESC OFF, Brake Warning, and Charging System Warning. Not having power electric steering would also make sense. Other symptoms: The rear defroster will not come on, and the fan speed won't go all the way up.
 

·
Registered
Sorento KX4
Joined
·
400 Posts
Discussion Starter #4
Just had a call from kia today to say it needs ABS sensor, so fingers crossed
 

·
Registered
Joined
·
966 Posts
I've seen this on other vehicles where the wheel sensor for ABS was corroded in the harness connector.
 

·
Registered
Kia 2015 Sportage Platinum diesel and 2013 Rio 3 door SLS
Joined
·
595 Posts
Sounds like you sold him a lemon :)

Hope this gets it fixed for him, and saves you a bit of face.
 

·
Registered
Joined
·
966 Posts
I shouldn't have read and posted on this thread - a few days after, mine threw the 'Descent' and 'ESP' lights one afternoon. Later that night I turned it on to check and they were still there. The next morning I started it again and they were still there, so I headed to the dealer. Halfway there they went out, so I came home. I've used it many times since, probably around 200 miles, and no more lights.
You know and I know that cars don't 'get well' by themselves, and I'll probably see them again, but since operation was not affected, I decided I'll take it in next time.
 

·
Registered
Sorento KX4
Joined
·
400 Posts
Discussion Starter #8
Yes that sounds like the same problem, they changed brake switch still all lit up so went on to change one of the ABS sensors all fine now and my father in law is a happy man again
and yes he did say have you sold me a lemon lol
 

·
Registered
Kia 2015 Sportage Platinum diesel and 2013 Rio 3 door SLS
Joined
·
595 Posts
Hope it's all fixed now.

When is he going to start doing some more mods to it . . . . if there is anything left to do!!!
 

·
Registered
Joined
·
966 Posts
We had a severe winter rain/wind storm with rapid temperature changes the night before so possibly some moisture formed and shorted a sensor temporarily. If I wasn't so trifling I would get under there, take each wheel ABS connector apart and grease it with dielectric grease. The brake switch has been known to cause the problem, but it's usually a failure, not intermittent. The only other problem I've had with it was the Crank Position Sensor that was not firmly connected. So Kim on the assembly line in Korea needs to 'man-up' and start putting them together right :)
 

·
Registered
2011 Sorento EX V6 AWD
Joined
·
30 Posts
This just started happening with my 2011 Sorento EX, exactly 2 weeks after I had the dealer do a spark plug replacement. Had never happened before. In addition to the 4 warning indicators intermittently being on, when I start the car and the lights are on the speedometer swings wildly sometimes up to 80 mph for a couple of seconds then settles down to 0 as I sit there. Could something have been knocked loose when the tune-up was done? I have an appointment next week to check it out.
 

·
Registered
2011 Kia Sorento SX AWD V6
Joined
·
30 Posts
This just started happening with my 2011 Sorento EX, exactly 2 weeks after I had the dealer do a spark plug replacement. Had never happened before. In addition to the 4 warning indicators intermittently being on, when I start the car and the lights are on the speedometer swings wildly sometimes up to 80 mph for a couple of seconds then settles down to 0 as I sit there. Could something have been knocked loose when the tune-up was done? I have an appointment next week to check it out.
Howdy, did you ever get a fix and or symptoms for this?
Cheers
Woody
 

·
Registered
2011 Sorento EX V6 AWD
Joined
·
30 Posts
I canceled my appointment since it didn't happen for a few days, and luckily it hasn't happened since.
 
1 - 14 of 14 Posts
Top