Kia Forum banner

1 - 20 of 26 Posts

·
Registered
Sorento SX FWD 2015
Joined
·
306 Posts
Discussion Starter #1
There already is a thread over on the 2016-2020 forum, thought I'd post it hear in case you do not follow that forum. Go to ' mapnsoft.com ' open an account, if you do not have one, or sign on . The update on an SD card for my '15 was $25.00 USD plus shipping, They say free downloads are coming in May. I do not have Canadian info as the site only supplies cost info for the VIN# entered on the order..

The thread on the 2016-2020 side, has more info in it. MapNSoft Kia Map upgrade
 

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
Good to know. I know the download for Canadian vehicles is different. I was told the US version would not working in the same Canadian vehicle. they charge more for Canadian download version. A money grab, maybe its force as a safety issue. Following old road maps can lead to accidents where the road no longer exist and there are quite a few here since my 2013 map built into our SX when released.
 

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
I went on yesterday and only update was the map SD card plus shipping to get it. $30 + $25 shipping so I bit on it. I believe its a bigger card but didn't study it too carefully. Light years better than close to $300 to get and update before. I am not certain on updating but instruction should accompany it. Pop out the old SD insert the new on and turn on the ignition is like all that should be needed expect. But it will be close to 2 weeks before I get the US Postal service package.

Hopefully it will fix a lot of Nav issue trying use the original one.
 

·
Registered
Sorento 2.2CRDi (2013)
Joined
·
116 Posts
Here is manual for 2017 SW version how to update your AVN, it is still valid. I updated to 2020 yesterday even I'm not using car navi as I prefer my online phone navi app.

It is covering all versions of used AVNs Gen 1x, Gen 2.x, Gen 4.x, iAVN:
list of AVNs.jpg
 

Attachments

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
Thanks, the 2015 and earlier is a different system as well as update package.
 

·
Registered
Sorento SX FWD 2015
Joined
·
306 Posts
Discussion Starter #6
Update experience....
My 2015 SX update arrived today, ordered Monday 4/27 arrived today Sat 5/2, US Postal delivery $6.10 USD , tracking showed it waited 2 days to get from shipping label cut in California to the post office for shipping to Georgia. Not bad for USPS lowest cost shipping option.
The install was nothing like the install instructions described. I removed my CD and USB (MP3) stick, shut off ignition, opened door to kill the Audio/Nav system power, removed old and inserted new SD card, started up the car. The UVO took off automatically with a verifying new data source message. It then started loading loading 1 of 6, 2 of 6, never saw 3 of 6, and 4 of 6 was slow as heck so I left update going on it's own, I came back in 15 mins to a completly dark screen. The install said it should take 20-25 mins, so I just left it another (15 mins) till a total of 30 mins passed. Screen was still blank so I inserted the CD and it played OK, inserted the USB and it playedd OK, hit the MAP button and map was displayed, went to setup and system info and it showed version 14 was installed. So basically I never had to hit a button or touch anything, contrary to the install booklet, it just took off automatically, and ended w/o any intervention needed. There may have been a message that could have cleared when I was away, Ill never know.
My car mfg date was 5/2014 my maps were at version 6 (6 years old) so I took a big jump to ver 14 plus updated the UVO code.
 

·
Registered
2014 Sorento SXL AWD
Joined
·
88 Posts
I only see an option for Hyundai vehicles there at mapnsoft.com. Update: Try Kia Mapcare | Customer Login

Did you get Android Auto with your upgrade?

BTW I don't see where it says they will be totally free. If that's the case I don't know if to wait the 10 or so days. I guess I would over write the old card assuming it would fit. There is supposed to be a new issue again in July. Nonetheless great deal. Thanks OP.
 

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
I've got the same vehicle and awaiting my shipment. Email sent its processed so just waiting.
Question: Was your engine running all that time?? Just wondering, I know the ignition would have to be on at least. How was this different from the booklet. Maybe the booklet was for a different NAV model using in 2016 or newer.

THX
 

·
Registered
Sorento SX FWD 2015
Joined
·
306 Posts
Discussion Starter #9
They really beat you guys/gals from Canada up on the shipping cost. Ign on w/o engine running should work for 15-20 mins it takes as long as you have a good battery. My battery is original in my'15 (six years old) so I was going to put the charger on it, but got lazy and figured burning fuel was easier.
As far as install, my install followed steps 1,2,3 in the book that came with the package. It took off automatically and steps 4,5 and 6 were not required it jumped to step 7. It did not go to step 8 as far as I know, I left it alone after step 7, when I came back the screen was dark w/no display. Checked out CD/USB/maps/destinations and verified verson on system info and all worked. Let my know how your 2015 update behaves, I hate when s/w updates don't follow the documented sequence, dosen't give a warm feeling. .
 

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
Yeah, they think we're made of money. Everything is so expensive to order to start with and we multiply by 1.4 at least for the currency exchange rate. thats a $1.40 for each US dollar at the moment. How much can a package with a SD card in it be. It so light. The existing card it 16 and the new is 32 as I recall ordering it.
 

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
As for installing with the engine not running. I know at times the radio circuit times out and turns off. Opening the door after turning it off. Using the Start button may have a time out as well. It constantly beeps warnings about running the battery down in this weird mode whether its truly accessory mode on not I don't know.
 

·
Registered
'14 Cadenza SX-L, '16 Sedona SX, Atlanta, GA, USA
Joined
·
279 Posts
I updated my Sedona in '16 a few months after I bought it. I left the pushbutton "on" (not on accessory) and it stayed on for the whole 30 minutes for the update. It seemed to take forever.

Just to clarify, I didn't press the brake pedal, so the engine didn't start, but ignition was set to "on"
 

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
I know there are at least two states if the brake isn't pushed that the stereo comes on. Its never clear which is what. I may have to read the manual again before attempting it or just run it but its a long time idling. I might as well go somewhere. LOL
 

·
Registered
'14 Cadenza SX-L, '16 Sedona SX, Atlanta, GA, USA
Joined
·
279 Posts
First press goes to "Accessory" mode, second press goes to "On" and third press goes back to "Off."
 

·
Registered
2015 Kia Sorento SX-Limited, AWD 3.3L V6, 41k miles
Joined
·
7 Posts
Update experience....
My 2015 SX update arrived today, ordered Monday 4/27 arrived today Sat 5/2, US Postal delivery $6.10 USD , tracking showed it waited 2 days to get from shipping label cut in California to the post office for shipping to Georgia. Not bad for USPS lowest cost shipping option.
The install was nothing like the install instructions described. I removed my CD and USB (MP3) stick, shut off ignition, opened door to kill the Audio/Nav system power, removed old and inserted new SD card, started up the car. The UVO took off automatically with a verifying new data source message. It then started loading loading 1 of 6, 2 of 6, never saw 3 of 6, and 4 of 6 was slow as heck so I left update going on it's own, I came back in 15 mins to a completly dark screen. The install said it should take 20-25 mins, so I just left it another (15 mins) till a total of 30 mins passed. Screen was still blank so I inserted the CD and it played OK, inserted the USB and it playedd OK, hit the MAP button and map was displayed, went to setup and system info and it showed version 14 was installed. So basically I never had to hit a button or touch anything, contrary to the install booklet, it just took off automatically, and ended w/o any intervention needed. There may have been a message that could have cleared when I was away, Ill never know.
My car mfg date was 5/2014 my maps were at version 6 (6 years old) so I took a big jump to ver 14 plus updated the UVO code.
Am new to this thread but I also have a 2015 Kia Sorento SX (L) version. How did you know what maps version was native to your car? Is that information contained within the SD card? The Kia manual says nothing about the SD card and I would like to update my maps. I am the second owner of this vehicle (new to me Nov 2019). Thank you for any information or suggestions that you can provide me.
 

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
Well you navigate through nav options I am not sure of the selection as I did it over 2 years ago and come to a screen like this which displays the info. Mine in this image is a 2013 build supplied new with the vehicle. Original ower never updated (extreme cost to do so likely).
 

Attachments

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
My Postal Tracking alert shows I should have in my post office at the beginning of the week Mon - Tues now. No postal service on the weekend to get it. until then.
 

·
Registered
Sorento SX AWD 2015
Joined
·
587 Posts
I got my SD card today. For my vehicle once the vehicle is started it auto starts the install. Nothing to do, but watch and the 6 step process was about 13 min and done. Screen goes blank after completed. It does stay their indicating it completed very long. Hence if you're not watching it, you're, well you know...LOL

Press the setup button and you're into the menu etc. All customized items likely lost as bluetooth phones have to be paired again. No big deal.
 

·
Registered
'14 Cadenza SX-L, '16 Sedona SX, Atlanta, GA, USA
Joined
·
279 Posts
I got the update for my Cadenza a week ago - install went smoothly, took 20-25 minutes. Maps have more detail, Bluetooth connections had to be reset, as did radio presets. Don't know about other models, but my Cadenza got a volume reduction while in Reverse.
Got my Sedona SD card yesterday. Will be installing it tonight.
 
1 - 20 of 26 Posts
Top