Kia Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a 2001 Sportage 2wd. I have a major oil leak when the engine is running. I can see it flowing from the left side of the engine but can't pinpoint its origin.

Some additional info: The check engine light is on. Had it checked and it says cylinder 2 is misfiring (makes sense as I don't have the power I used to.) Checked the forum and plan on changing the plugs, PCV valve, and the valve cover gasket, as I can see oil seeping out on the right side (can't see the left side well enough.)

Could these two problems be related? Could the valve cover be leaking so bad on the left side (that I can't see) to be losing so much oil when running? BTW, it only seems to be leaking/flowing when running. They seemed to both happen at the same time.

Thanks ahead of time for any help you can give, and sorry if this seems like I'm rambling. I'm just a little freaked out with the major oil leak. I just moved out of state from my family, don't have any friends here yet that can assist, and on top of that, just got "downsized" from the job I moved here for. This is just another major hit I did not need now :eek:.

Thanks again.
 

·
Registered
Joined
·
2,268 Posts
You really need to find out (where) the oil is leaking from - at the top-end or further down on the motor..

I've found it helpful in the past to give the motor a thorough cleaning, removing any visible oil / scrubbing with a soft "wheel" brush & using Simple Green to remove accumulated oil & dirt, start and run the vehicle up to operating temp., then use some (blue) shop towels after the vehicle has cooled down to wipe over the suspect areas / identify where the leak is coming from ..

*If the valve cover gasket, it is likely it is also leaking (inside) the coil pack chamber: if you pull the coil pack cover & find oil in the spark plug wells, a common issue, be sure to soak up / wipe up the excess oil -before- removing the spark plugs,

Regards,
GottaCruise
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks, I'll do that. In the meantime, I quickly cleaned up the area and I think it's leaking from the mount that the oil filter screws onto, between the block and the mount. I assume there is a gasket there that must need to be replaced. I don't see anything leaking above that. It is an oily mess above it which is probably from the oil being sprayed upward while I'm driving. Could you possibly tell me what the name of that is so I can get the gasket? And if there is anything special to removing that mount that I should be aware of?

Thanks again for your help.
 

·
Registered
Joined
·
2,268 Posts
1 - 4 of 4 Posts
Top