Kia Forum banner

1 - 3 of 3 Posts

·
Registered
05 sorento 08 sorento
Joined
·
22 Posts
Discussion Starter #1
i have replaced the alternator twice and battery twice in my 05 ex 4wd sorento. i still cannot get a proper voltage from the alternator. it hovers around 13 then goes down to 12.8 when everything is on. when i drive with everything on the truck studders and will sometimes not shift right. i thinking because of low voltage. any ideas???
 

·
Registered
'96 Camry v6 XLE, '00 Camry LE
Joined
·
2,174 Posts
Greetings,

Would recommend signing up at the kiatechinfo website (see my sig.) using Internet Explorer browser, then you can view the (Service Info.) -> and test procedures for your vehicle -

An in-line voltage meter / ammeter test is indicated to check (amp) output of the alternator, to diagnose & further troubleshoot issues with the output (B+) wire -> and/or the electronic voltage regulator (quoting from the test procedure).

At a minimum, I would also be inspecting all battery cables and cleaning all ground points: battery terminals, battery neg. cable to frame, at a minumum.

Test procedure located at:

SORENTO(BL) >2005 > G 3.5 DOHC > Engine Electrical System -> Charging System -> (Repair Procedures)

Regards,
GottaCruise
 

·
Registered
05 Kia Sorento LX 4x4
Joined
·
280 Posts
That's about right. I thought the same about mine (~12.7v all on). Bought a new alt, pull the old one out, and it had 13v printed on it. It's NOT a standard 14.4V system, it's designed around 13v instead. Brand new Alternator was running 12.8v all on.
 
1 - 3 of 3 Posts
Top