Kia Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi all just went down the road a drive and noticed that my kia had no powe wouldnt go above 50 , when i took out of gear and reved the engine it reved a wee bit but made a strange noise , so pulled over and turned car off , started again and all was ok ! could this be the egr valve ? its 2009 ceed sw thanks
 

·
Registered
Ceed 1.6crdi ('07)
Joined
·
648 Posts
Given that it cleared itself it doesn't look like a mechanical problem. The ecu may have seen a momentary out of range value from a sensor and went to limp mode; it might have a diagnostic reading that can be read out.

Because a diesel does not have a throttle, the ecu isn't obliged to deliver a certain amount of fuel according to air supply so it can turn things down at a whim.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
its at 47295 also it was in the kia garage a few days before cause the water in fuel light was coming on ,so kia reckoned that it was a faulty sensor , pretty common they said , and they changed the filter aswell , could that have anything to do with it , kia says no .......
:huh:
 

·
Registered
Ceed 1.6crdi ('07)
Joined
·
648 Posts
its at 47295 also it was in the kia garage a few days before cause the water in fuel light was coming on ,so kia reckoned that it was a faulty sensor , pretty common they said , and they changed the filter aswell , could that have anything to do with it , kia says no .......
:huh:
Might be a poor connection in the wiring.

Assuming you have a UK model, the '09 doesn't have a dpf to worry about.
 

·
Registered
Kia pro ceed 3 2013
Joined
·
271 Posts
its at 47295 also it was in the kia garage a few days before cause the water in fuel light was coming on ,so kia reckoned that it was a faulty sensor , pretty common they said , and they changed the filter aswell , could that have anything to do with it , kia says no .......
:huh:
Had a big drop in power output on a Skoda Octavia at various times. When checked at garage the fault did not show. After another loss when overtaking it turned out the cars turbo was dropping out. Garage then changed a card and problem solved.
 

·
Registered
Cee'd VR-7
Joined
·
391 Posts
My previous car, a Mitsubishi (Petrol) Colt, started to get the same problem after it was about three years old. The car would occasionally have virtually no power on start up and the engine management light would come on. If I turned the ignition off, waited a couple of minutes then started again all went well. However, the warning light stayed on after for about 24 hours before going out. After numerous trips to two dealers over 18 months the problem still persisted. In fact this was the main reason I got rid of the car (God help the new owner!)
 
1 - 10 of 10 Posts
Top