Kia Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
Hey All,

Our 2014 SX V6 (68k miles) has started to suffer from a long cranking issue. Sometimes it will take a few seconds for the car to turn over. Once it starts, it runs fine. Some preliminary Googling points to a possible failing high pressure fuel pump. It's going to the dealer next week since it's under extended warranty, but wanted to see if anyone else has had this issue and had it fixed.

Thanks!

Lew
 

·
Registered
Joined
·
171 Posts
Let us know what the dealer finds, I'm thinking maybe a bad check valve in the Low Pressure pump (in tank) could be leaking the fuel back into the tank after shutdown and HP pump has to wait for fuel. The shop may perform a 'pressure leak down' test in the LP fuel line to check this out. The way to verify this in fuel injected cars is to turn key from 'off-IGN-off a couple of times prior to cranking. The ECM, anticipating a startup, normally runs the electric pump 2-5 seconds to pressurize the lines when it sees the off-to-Ign sequence. Not sure of this trick would work in these cars. Specifically with PB starting (2-presses w/o depressing brake). I have PB start and starts so fast I have never actually heard the fuel pump start running, on my other cars the pump humming for 2-5 seconds after off to IGN w/o cranking it is very predominate. In fact, it's a standard procedure to prime the fuel lines when starting my 25 year old Camaro that sits for long periods waiting for the sunshine to get out of the garage.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #3
Welp, took the car to the dealer on Saturday. Had a laundry list of issues for them to sort out. Unfortunately, the long cranking issue has become more intermittent and they could not reproduce it. On a good note, they fixed the trans issue, adjusted the low beams, and found leaks in my power liftgate struts that was probably causing the squeaking which should be covered under our extended warranty. So I guess there's that. :D
 

·
Registered
Joined
·
349 Posts
... On a good note, they fixed the trans issue, ..
What was the issue ? (maybe part of another thread...).
From day one ..when I bought the car at 55000km, the first 2-3 shift of the day is sluggish..and ets the engine rpm rev up. Never again in same day. "They all do it", says the dealer...adding "shift in reverse first in first start of the day...it will be OK" and yes, it is OK. I blame it on an accumulator that bleeds off in the night....reverse fills it up.....
 

·
Registered
Joined
·
100 Posts
Discussion Starter #5
What was the issue ? (maybe part of another thread...).
Between 60-70 mph, it felt like the trans was hunting for a gear or didn't know which gear to be in. Like it wanted to downshift, but then realized the car was going 80 and decided to stay in 6th. I think the fix they put was "updated the values". It does shift MUCH better and initial testing on the hwy has been positive with no signs of the orig issue.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #6
Update on the long start issue. It appears that the battery was the culprit. They tested it and it was able to hold a charge at 96%, but the CCA values dropped from new (660) to 361. New battery was installed and so far....So good.
 

·
Registered
Joined
·
67 Posts
My 2.4L 2014 cranks a long time before it starts when it's cold. I say about four seconds before it starts up. When it's warm it starts up instantly.

It's turning over fine though. Just doesn't want to spark right away when it's cold.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #9
Mine usually happens when the engine is still warm. It's not normal far as I can tell for the V6. There's all sorts of stupid issues surfacing now that I've reached 70,000 miles.
 

·
Registered
Joined
·
387 Posts
Depends on a lot of factors. Even fuel you use most of the time if NOT TOP TIER GAS build up in the GDI engine will occur and require fuel system based flushing to decarbonize the engine.

the owners manual specifice TOP TIER should be used. My engine should be the same as your as is the build other than 2015.
 
1 - 13 of 13 Posts
About this Discussion
12 Replies
5 Participants
Sweet Lew
Kia Forum
Kia Forums is a community dedicated to all Kia models. Come discuss the Kia Sorento, Rio, Sportage, Soul and more!
Full Forum Listing
Top