Kia Forum banner

1 - 7 of 7 Posts

·
Registered
2016 Kia Forte LX 1.8L 2013 Kia Forte SX 2.4L
Joined
·
109 Posts
Discussion Starter · #1 ·
Hello, recently I had a issue with my turn signals not working most of the time. Now they quit working all together except the hazards.. Now I just replaced with a new OEM turn signal switch, thinking that was the issue, but it turns out it is not.. what I need is a actual photo of were the flasher unit or relay is located.. Kia global solutions pages, show one, but the diagram is not IMOP very good. In their picture it shows the location being straight up and down. but if I found the right one it is not. I also can't figure out if it is on the left side of the steering colume or right. I have found many people on the net asking for the same thing, for this same car, but each diagram is different and actually listed for a different yr not the 05-10 models.. Thanks again.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts
Hi...
I know on the KIA Spectras from 05 on...that the flash (timed on/off) function comes from the BCM (body control module) so it's probably the same with the 06 Sportage...NO FLASHER just problems with the BCMs and their internal software/hardware...
Maybe other Sportage users can chime in with more info..
Dave
 

·
Registered
2016 Kia Forte LX 1.8L 2013 Kia Forte SX 2.4L
Joined
·
109 Posts
Discussion Starter · #3 ·
Hi

I did manage to remove that flasher. It is for the hazards and flashers themselves. I removed the cover, turned on the signals and hazards and it seemed to work. but once you but the cover back on, it was back to the same thing. I'm going to order that and the hazard switch, and replace them both. then I would have replaced all three items and if the problems persist, then I will check the bcm. Might go ahead and look that up as well. thanks
 

·
Registered
2016 Kia Forte LX 1.8L 2013 Kia Forte SX 2.4L
Joined
·
109 Posts
Discussion Starter · #4 ·
I just did some research on the BCM. The 05 06 07 do not ocme equiped with it.. Model 08 09 10 model yr do.
 

·
Registered
Sportage 2006
Joined
·
7 Posts
I'm glad you found the flasher unit but you didn't tell the rest of us where it is. I found this to be a real mystery on this site and on the whole web. I did find it on my 06 sportage. It is on the right side of the steering column under the dash. If it still works enough to click a couple of times you can find it by hearing and when you touch it you can feel the clicks. It is in a horrible position and difficult to get out. I removed the nut that holds it in then didn't bother putting it back where it came from. I will just tape or tie-wrap it to something in a few days. If I were to do it again I would just try to break it off the tab that holds it then let it hang or tape it when I was done.
 

·
Registered
2008 Kia Sportage LX
Joined
·
1 Posts
I'm glad you found the flasher unit but you didn't tell the rest of us where it is. I found this to be a real mystery on this site and on the whole web. I did find it on my 06 sportage. It is on the right side of the steering column under the dash. If it still works enough to click a couple of times you can find it by hearing and when you touch it you can feel the clicks. It is in a horrible position and difficult to get out. I removed the nut that holds it in then didn't bother putting it back where it came from. I will just tape or tie-wrap it to something in a few days. If I were to do it again I would just try to break it off the tab that holds it then let it hang or tape it when I was done.
How were you able to remove the nuts from there?
 
1 - 7 of 7 Posts
Top