Kia Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
https://www.kiatechinfo.com/signup_main.asp

Has anyone been able to get an account and log onto kia Tech info page.

I have tried registering but when submitting the info you must read and check off the user agreement . When clicking on the link for the agreement all I ever get is a blank page.

Wondeing if this has happened to others and what steps can be taken to register
 

·
Registered
Tanz. Blue 2012 Rio Sedan,Al White 2013 Toyota PriusV
Joined
·
384 Posts
https://www.kiatechinfo.com/signup_main.asp

Has anyone been able to get an account and log onto kia Tech info page.

I have tried registering but when submitting the info you must read and check off the user agreement . When clicking on the link for the agreement all I ever get is a blank page.

Wondeing if this has happened to others and what steps can be taken to register
Welcome to the forums. Yes we have numerous members who use this for everything!

It is most likely your internet browser. I had to use internet explorer just to see the page and register. Once you make your account then you can use any other browser you want.

Hope that helps, cheers

PS: Update your location information when you get a chance ;)
 

·
Registered
Kia Rio YB . GT-line 2018
Joined
·
220 Posts
this are the Requirements
wil only work on internet explorer
i use is for a while an it works great
do not forget to instal the svg viewer



System Requirements: Windows 98SE, ME, 2000, XP, 64MB RAM, 1024x768 video resolution, Internet Explorer 6,
High-Speed (128K or greater) Internet connection,
Full-Screen Mode (press F11 in Internet Explorer) is recommended for best viewing.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,959 Posts
More clarification here...

Windows computer (98~win7)

Internet Explorer ver 6~8 (ver 9 or 10 "may" be usable with "compatibility mode" enabled)

Adobe SVG (scaled vector graphics) downloaded and installed.

A "valid" email account that they can respond to...

kiatechinfo.com uses "older" Microsoft Windows Server software and also outdated (no longer supported) Adobe software... They have not updated this site for quite sometime BUT they do have a lot of GREAT info available for FREE.

Maybe one day they will put some money and time into this site but I'd hate to loose the "FREE" connection and I'm willing to use it "as-is"...

You CAN'T use other browsers (Safari/Firefox/Chrome/etc...)
You CAN'T use MAC or Linux Operating systems
Dave
 

·
Registered
2012 Rio SLi 'Latte' 6AT 1.6GDi
Joined
·
126 Posts
More clarification here....

You CAN'T use other browsers (Safari/Firefox/Chrome/etc...)
You CAN'T use MAC or Linux Operating systems
in order to access the site, I'll have to use the bootcamp partition? no wonder why I could never get onto it!
 

·
Registered
2007 Kia Spectra SX
Joined
·
10 Posts
I originally registered on the site using Internet Explorer 10. Once I was registered I can log in fine using Chrome (current version I'm using is 27.0.1453.94 m).

Sometimes the popup windows stop loading fully so I just restart my session (close the tab and navigate to the site again, which usually requires signing into the site again).
 

·
Registered
former owner of a 2016 Soul SX 2.0L - Caribbean Blue
Joined
·
8,526 Posts
been using ever since I joined this forum and a great source of info. IE works best but you can get quite a lot of info with Firefox and Chrome but it won't do everything that IE does. It's based out of California and the also have a toll free number if you have problems. Here is three of the pages to give you an idea.





 

·
Registered
2012 Kia Rio 5-Door LX
Joined
·
301 Posts
conwelpic, I have to agree, without KGIS I would not have been able to do the few mods that I've done so far. The repair procedures and the component lists are quite helpful.
 

·
Registered
2013 Rio 5 EX, 1967 Chevy C10
Joined
·
241 Posts
Thanks for sharing the info about having to use Explorer. I had tried both Firefox and Safari to try and sign up.
 

·
Registered
2013 KIA Rio SLi, 2007 FORD Falcon BF XR6
Joined
·
26 Posts
I tried creating an account but it keeps asking me to check the Privacy Policy and User Agreement. I click 'Confirm' but it repeats the same message!
 

·
Registered
2017 KIA Forte5 SX, 2017 KIA Sportage EX Lux, 1986 Pontiac Fiero SE 2m6
Joined
·
77 Posts
When creating an account - you MUST use INTERNET EXPLORER to proceed. If you are trying with Chrome, a repeat message will occur.

If you've got a Mac, sorry - a VMWare/VirtualBox/BootCamp install will work.

Once you have your account created, you MAY be able to use Chrome or Firefox; but IE is recommended.
 

·
Registered
'13 Rio5 // LX Clear White w/ Pwr Pkg
Joined
·
83 Posts
Im on a Mac, tried it with Safari, no dice.
 

·
Registered
2013 KIA Rio SLi, 2007 FORD Falcon BF XR6
Joined
·
26 Posts
I did use Internet Explorer and it didn't work.

Can someone please setup an account for me :)
 
1 - 13 of 13 Posts
Top