Kia Forum banner

21 - 40 of 40 Posts

·
Registered
2004 Kia Sorento
Joined
·
13 Posts
Discussion Starter #22
Thank you very much.
If I’m not getting full voltage then my only options would be bad connections or a bad tcm module ? Or could it also be a bad ecu ?
 

·
Registered
2004 Sorento EX
Joined
·
1 Posts
Did you fix the 4WD/TOD issue?

I'm having a very similar issue to the one you have described and I'm hoping you found a solution?

So far I have:


  • Replaced the clutch pack according to TSB-022
  • Replaced the TOD PNL ASSY - (thinking maybe bad switch)
Considering replacing the Electronic Transfer Control Unit next...

Any information about how you solved the problem would be much appreciated!
 

·
Registered
Sorento 2.5 CRDI EX MAJOR 2004 240 000km
Joined
·
9 Posts
Hi all, i have buy this month a nice sorento ex major 2004 with 240 000km, i have similar problem:

-in 4X4 or in 4X4 low i have only rear wheel in rotation. ''mud test''

4X4 low mod sometimes the mode starts, but some day, he doesn't want to know anything ...

*Also the green light of traction control is blinking.

Before unmont my transfertbox, i want to test the harnais of the system tod for
possibly find false contacts.

Help me Best regard !
Wood south of France ^^
sry for my bad English
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,762 Posts
First, have you checked underneath for shaft between transfer case and front axle?
Second, have you checked fuse 13 ('TCCS') driver's footwell fuse box, is intact and functional (use a continuity tester on fuse)?
If the vehicle has had problem with transfer box then one or both of above may have been removed to hide it.
 

·
Registered
Sorento 2.5 CRDI EX MAJOR 2004 240 000km
Joined
·
9 Posts
Bonjour Gee6 thanks for your help,

Yesturday i have checked underneath and all seems ok, front axle, shaft and trasfert box are here.
Fuse 13 is ok not burn and the test of continuity is ok

I put dexron 3 + to drain the transfer
Maybe the current oil has no friction
the error of traction green message may be due to a sensor, ecu?
can it be possible to verify them?

thanks you!
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,762 Posts
If you have a TOD transfer case, Dexron 3 is the wrong oil. You need proper Kia Transfer case oil or add a small bottle of friction modifier to the dexron 3. (Kia changed the oil spec years ago.) Not certain from your post which transfer case you have.
 

·
Registered
Sorento 2.5 CRDI EX MAJOR 2004 240 000km
Joined
·
9 Posts
Transmission manuel, blink 4wd at 1sec of frequency, i don't no for shift motor. But low mod work very well for the moment.
Today After rear axle drain i start motor the 4wd green led is off.
I drive 8 km, i stop engin, i restart after 10 min and the 4wd green led blink...
It is not easy to find '' the right oil '' for this transfer case.
Could you advise me the most effective?
I also have the solution to mix '' modify friction '' with '' MANNOL Dexron III Automatic Plus '' but I can't find which one.
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,762 Posts
OK, I see what you are getting now. Bit difficult as I have facelift automatic and could not directly translate. What I see as possibilities for this situation as follows: (Blinking warning lamp)

Electromagnetic Clutch (EMC) - Open circuit / Shorted to Battery / Shorted to ground. [TOD Halted]

Shift Motor - Open Circuit / Shorted to Battery / Shorted to ground. [No Shifts]

Shift System Timeout. (Probably not relevant)

All above conditions should generate an error code P17nn. I think I would consider checking all the connectors and harness for damage assuming you cannot narrow it down by finding a code. It certainly seems to be electrical.

Jeep used to have a friction modifier - here there are several on aftermarket. I have never had to use such but I'm told "small bottle". Most seem about 120ml. For Example: Dodge-Jeep
 

·
Registered
Sorento 2.5 CRDI EX MAJOR 2004 240 000km
Joined
·
9 Posts
I will check the electrical harness and I will keep you informed.
Thanks you very much for your help,
Have a good holiday and see you next year!
 

·
Registered
Sorento 2.5 CRDI EX MAJOR 2004 240 000km
Joined
·
9 Posts
Hi, i have found this:

is less expensive than a Dodge-Jeep, I hope it will do the trick.

Today i have checked harness, it seems good,

I don't know how to check my all sensor, and the one on the back is difficult to extract. (body inside to the box)
ECU was checked simply, with the eye, no resistance burned, just a little resin, left in some places.
113367
113368
113369
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,762 Posts
Don't know what to suggest next. Maybe you will need to check continuity across pins of connectors to verify if they are actually working ...... not unknown for issues with connectors especially where exposed to elements. Or consider a proper diagnostic check to see if specific error codes are visible.
 

·
Registered
Sorento 2.5 CRDI EX MAJOR 2004 240 000km
Joined
·
9 Posts
when I measure with multimeter the voltage between the coil clutch wire and the ground, I have a value between 13 and 14V motor started hight or low mod
what do you thinks ?
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,762 Posts
I think I'll have to think! Full battery Volts on the coil does not sound right to me. (The coil should operate on a varying voltage depending on the torque transfer requirement of the TCCU.) Full volts implies full engagement of the clutch and I don't think that should happen when standing still......
 
21 - 40 of 40 Posts
Top