Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi!
I’m writing this post the best I can, since I don’t speak/write very well in English. I’ve seen a lot replies in other posts so I hope someone could give me some help.
I have a Kia Soul 2010. I’m having troubles with the A.A blower. Sometimes I turn the A.A fan knob on and the blower won’t start until i snap/punch around the area below the center console. Other thing I notice is that the speed tends to “vary”. I can hear and feel the wind oscillating.
Has anyone had this issue? Is it possible that the brushes are the problem?
 

·
Super Moderator
99 Kia Elan 1.8L
Joined
·
11,308 Posts
Hi!
I’m writing this post the best I can, since I don’t speak/write very well in English. I’ve seen a lot replies in other posts so I hope someone could give me some help.
I have a Kia Soul 2010. I’m having troubles with the A.A blower. Sometimes I turn the A.A fan knob on and the blower won’t start until i snap/punch around the area below the center console. Other thing I notice is that the speed tends to “vary”. I can hear and feel the wind oscillating.
Has anyone had this issue? Is it possible that the brushes are the problem?
Using the below link, please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.

eg.
Argentina
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature


https://www.kia-forums.com/threads/forum-rules.27240/


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 
1 - 2 of 2 Posts
Top