Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Kia Sedona 2.9 CRDI TS 2007
Joined
·
3 Posts
Discussion Starter #1
Hi, I am by no means a Kia expert, I am a classic car restorer by trade but have played with plenty of modern (old now) rovers, anyhow...

So I have my 5 speed Kia Sedona 2.9 now cutting out with the engine light on, it drives for about a minute maybe 2, then cut with out, select neutral and start again on the move.

So far if done the standard drain fuel and new filter, fitted a new AMV (£130!!) and still my issue persists, so I should have done this first, did overflow test on injectors and pow 2 down, significantly more overflow, which leads onto my question, I’ll strip all 4 down tomorrow may as well do them all, what torque settings do they screw together at? And if I refit each injector in its original port will it need coding at all? Also prior to this issue she ran fine, until I removed the cat, greatly boosted MPG fuel economy! I was getting low 20’s now I’m way up into the late 30’s

So those are my questions torque settings for injectors and do they need recoding after being rebuilt??? Thanks a million
 

·
Premium Member
2019 KIA Sorento SX - 3.3L GDi V6 - AWD
Joined
·
955 Posts
113202
 

·
Registered
Kia Sedona 2.9 CRDI TS 2007
Joined
·
3 Posts
Discussion Starter #3
Well just done the two injectors that had gone down and started it up engine light was on briefly then turned off took her for a drive and she’s a lot lot lot better again!

I’ll tear down the other two injectors tomorrow as me and my pregnant wife have a hospital appointment at 5pm today, but I’ll post some photos of how the injectors tear down and how I cleaned them
 
1 - 3 of 3 Posts
Top