Kia Forum banner

1 - 13 of 13 Posts

·
Registered
kia rio 2001 , Mitsubishi Galant 2004
Joined
·
37 Posts
Discussion Starter #1
Hi some time ago i posted a problem related to this but im gonna start it fresh .

My old rio is giving me

1. P0444
Evap emission control system purge valve c open .

2. p0340
Camshaft position sensor A - bank 1 cicuit malfunction


3.p0032
ho2 bank 1 sen 1 heater circuit high

and this is what ive made ..

1.Check all the plugs and cleaned them with Elec cleaner
2.changed the ecm
3.changed the cam sensor 3 times
4. checked and cleaned all the sensor
6. Changed idle air control valve
7.changed fuel.pump
8. Timming belt checked

I clear the codes and they come back again im thinking of replace the MAF.sensor.too .
the car was really weak on.idle now.is a.bit better but not at it optimal .
wht i.should do next ...?

thanks
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,866 Posts
First...Welcome Jeam to kia-forums...
Second...You have not solved the problems and that's why they keep coming back..
Let's see what we can do for you...
1. P0444
Evap emission control system purge valve c open .
This valve is located close to the fuels carbon canister and is part of the air pollution garbage... Gas fumes are sucked into the canister from the gas tank and then are burned rather than releasing them to the open air. The solenoid controlled purge valve
is probably bad or your gas cap has a bad rubber seal...

2. p0340
Camshaft position sensor A - bank 1 circuit malfunction.
Older KIAs are known for bad grounds and corroded wiring harness plugs and connectors. Look for wires bolted to the body/frame and remove the bolts clean underneath to shiny metal and apply silicon grease to keep out air/salt/water.
Pull apart the harness' plugs and sockets and look at the pins for oxidation (usually green or yellow/orange color). Clean up any corrosion found and again add silicon (spray). Also another thing comes to my mind... CHECK your fuses...both under the hood and in the passenger compartment. This may also be causing your #3 problem.
3.p0032
O2 bank 1 sen 1 heater circuit high
There is a a coil of wire within the O2 sensor that heats the sensor when the car is running to allow better sensor readings. There is +12v going to the coil/heater on one wire and a ground is turned on (within the ECM) when the car is running.. Because you have replaced the ECM (they usually DON'T fail btw) I would check the fuses, connections at the O2 connector and possibly check for a low resistance across the O2 heater connections.
You can also check out kiatechinfo.com BUT it is ONLY written in English. If you wish to try the site I will provide how to gain access in another post.
Good Luck!
Dave
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Hey Jeam25, One thing i would check is your main relay. It's an old car right and it supplies 12 VDC to the cam sensor, o2 sensors, canister close valve purge controll valve and AC Relay. Try swapping it out with a good one if you can. Just trying to help. Also check your connectors and grounds. Good luck. Reguards Ronjohn
 

·
Registered
kia rio 2001 , Mitsubishi Galant 2004
Joined
·
37 Posts
Discussion Starter #5
Hi and thanks to all ...!

Im working on it ...i let you know !!

THANKs !
 

·
Registered
kia rio 2001 , Mitsubishi Galant 2004
Joined
·
37 Posts
Discussion Starter #6
Hi i cant find the purge solenoid valve .... where is it ?
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,866 Posts
The purge valve is "probably" located under the car in back of the gas tank under a plastic shield.... That's where "most" of them are located..It is normally attached to the activated carbon canister....Look for wires (2) going to the solenoid.
You need to sign up at kiatechinfo.com... There is EVERYTHING your heart would want for your RIO...
Here's a cut and paste on how to get on properly...Follow the instructions closely and use a mainland US zip code like mine (44646)
Start...

You really don't need to "buy" a manual...Just go to "kiatechinfo.com",
register, and all the info you need is right there.
You need to be running
Microsoft Windows (XP,Vista,7) and
Microsoft IE (Internet Explorer 8 or higher).
You also need to download and install a free "plug-in or app" called Adobe SVG
(Scaled Vector Graphics). There is a link to this software on their site.
and a valid email address to send the password to..
This is the only known good way to get onto this site..
This site does NOT like Macs/Linux OS or Safari/Firefox/Chrome browser software.
Follow the above EXACTLY and you will get on...

There is a moderate learning curve as things aren't always where you would think they should be...but a little looking gets everything you could possibly need.
End....
We are here also to help and want to answer any questions you have.
Dave
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Jeam25, the purge valve should be in the line from the charchol canister to the intake manifold it should be somewhere in the engine compartment follow the hose from the canister to the intake manifold it should be there somewhere i can not remember for sure good luck and do not forget to go over your wiring/connections and that main relay for sure that seems to be common to thoes sensors check that a critter did not chew them somewhere. Good luck trying to help , Reguards Ronjohn
 

·
Registered
kia rio 2001 , Mitsubishi Galant 2004
Joined
·
37 Posts
Discussion Starter #9
Hi ...the code P0444 was resolved . It was a the plug that goes conected to the valve or solenoid that.it wasnt conected for.some.reason .

Now the other 2 are there . i replaced the maf sensor too and the sensor speed because the speed meter it wasnt.working ..

As far i can see all the plugs connectors and cables good . I dont know if im missing a ground cable somewhere ...

some times it making me a false start with a loud noise .
I saw long time ago that can.be the knock sensor ..

What i should do.next ???


Thanks again to.all
 

·
Registered
2012 Kia Soul+, Kia Sportage SX FWD
Joined
·
472 Posts
I seem to recall reading the camshaft pos sensor that is attached to the cam can come loose and cause a cam sensor malfunction code... You would have to remove the valve cove and see if you can check that sensor ring attached to the rear(intake) camshaft. Make sure it is tight and not wobbling loose on the camshaft. Never had this problem or looked at it myself, but read someones posts a year ago on the subject. Might do a search and try to find that camshaft sensor post.
 

·
Registered
kia rio 2001 , Mitsubishi Galant 2004
Joined
·
37 Posts
Discussion Starter #11
Hi thanks the cam is good ...another thing im noticing is that the car brake pesal is hard and the brakes weak while the car is cold ...



??
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Maybe loss of vacuum, for hard brakes and weak response look for a bad hose somewhere maybe an issue Good luch Jeam25 vacuum leaks can cause issues with the engine and brake booster esp the hose that runs from the pcv valve to the intake manifold i replaced mine very brittle after 10 years and leaking good luck. Reguards ronjohn
 

·
Registered
kia rio 2001 , Mitsubishi Galant 2004
Joined
·
37 Posts
Discussion Starter #13
Hi...

After a looooong time i discovered that the cam sensor and the knock sendor were
exchanged .....so this whole time the car war runing that way.....OMG !!

Now the cam error and the other error are gonne .... And the car i runing very well now..
Now i need the timing screw or whatever is named ...the screw on throttle side that adjust
the idle tempo or revolutions .....

And i want to replace the big rubber gasket that conect the MAF and the throttle but i dont ut name ....

THANKS TO ALL AGAIN !!!
 
1 - 13 of 13 Posts
Top