Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello
I have a KIA RIO 2012 1.1 DIESEL INSTYLE 5D and after the 11.000 klm i had the first engine light ON :eek: for some kilometers - after that i am getting often that light ON without any reason and stays light for acouple of days then goes out and again on after 1-2 days - i took the car a lot of times in the service of local KIA mechanics but they found nothing :confused: - they told me that they wait an answer from the constructor to tell us what is going wrong with this car :eek: - does any other have a problem like mine :mellow: ? and if he did what was the solution?
THANK YOU!!!
 

·
Registered
Kia Rio S 2012 (3-door hatchback)
Joined
·
41 Posts
Perhaps it is to do with the oxygen sensor in the fuel tank? I had an engine light coming on and off periodically in my previous car and the mechanic said that it was the oxygen sensor (which is a very common problem by the way - just too high oxygen level in the fuel tank). Apparently it's nothing dangerous but it might be a good idea to get an independent mechanic to confirm the fault code (to see what the problem may be).
 

·
Premium Member
'12 Rio SLS, '13 XR6 Turbo, '15 XR8 S/C
Joined
·
995 Posts
i think you're going to just have to wait until the dealer works out what's wrong. Unfortunately they're not all that good at it when it's a random thing.

Perhaps it is to do with the oxygen sensor in the fuel tank? I had an engine light coming on and off periodically in my previous car and the mechanic said that it was the oxygen sensor (which is a very common problem by the way - just too high oxygen level in the fuel tank). Apparently it's nothing dangerous but it might be a good idea to get an independent mechanic to confirm the fault code (to see what the problem may be).
the o2 sensors are in the exhaust, not the fuel tank! it feeds info back to the ECU based on the mix in the emissions flowing past
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I will wait few days to see if there is any solution from the Central department of KIA - as they told me they have send a replay of this issue to Main Factory - thank you anyway - i am going to apply a question to main service about O2 sensor.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
i went again to service station and they found that the obd2 gives a code that has no response for my car - my car has 3 injection and the obd2 says that the number four injector has problem - they kept my car at the service for more inspection
 
1 - 6 of 6 Posts
Top