Kia Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My stepdad pulled the battery out of my kia to charge it as it had gone flat while i was on holiday i put the battery back in and the indicator on the right hand side (drivers side) is lit up solid (not blinking) and the the wipers are stuck on

Did i put the battery on wrong, could the connector be loose, have i gotten the polarity wrong or is this a kia security feature???? Did i blow a fuse?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
I think i figured it out, i wass told the wrong direction of the battery when he pulled it out the dash lightd all come on and go when turning 9ver the car the fuel guage comes up to where it should and the wipers and indicators work so it doesnt look like i damaged the computer or the wiring its got some really old fuel in it at the moment so that will be why its not starting up and the problem dad mentioned about him not being able to get it out of parki m currently (uneducated guess) putting down to it being an automatic so the engine needs to be running before i can switch gears
 

·
Moderator
99 Kia Elan 1.8L
Joined
·
12,116 Posts
My stepdad pulled the battery out of my kia to charge it as it had gone flat while i was on holiday i put the battery back in and the indicator on the right hand side (drivers side) is lit up solid (not blinking) and the the wipers are stuck on

Did i put the battery on wrong, could the connector be loose, have i gotten the polarity wrong or is this a kia security feature???? Did i blow a fuse?
Using the below link, please add location and vehicle (year & model) to your Profile/Account Details

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

Kia Forum


Forum Rules


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 
  • Like
Reactions: Papamax

·
Moderator
99 Kia Elan 1.8L
Joined
·
12,116 Posts
My stepdad pulled the battery out of my kia to charge it as it had gone flat while i was on holiday i put the battery back in and the indicator on the right hand side (drivers side) is lit up solid (not blinking) and the the wipers are stuck on

Did i put the battery on wrong, could the connector be loose, have i gotten the polarity wrong or is this a kia security feature???? Did i blow a fuse?
Using the below link, please add location and vehicle (year & model) to your Profile/Account Details

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

Kia Forum


Forum Rules


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top