Kia Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
5th May’05 midnight, when I crank the car, the engine was vibrating vigorously even when I tap on the accelerator. The engine sounded like a bump boat or you can put in a nicer way by saying it sounded and vibrates like a heavily modified Subaru WRX STI boxer engine . The engine check light came up too!

After several attempt the next morning, I finally was able to had the car driven back to the dealer the next morning when the engine “seems to be back to normal” but with check light on. When collect car in evening, I asked SA what was wrong and what had been done?

I was told that the engine had mis-fired and upon using the state of art diagnostic computer, 3 fault codes were detected P300, P301 & P302. The remedy was to clean the fuel injector and re-set the ECU .

My question is, with 3 fault codes detected; surely something is wrong with the car. Else, why did the car mis-fired since it is an EFI engine ? They couldn’t answer. And can cleaning the injector resolve the root of the problem? I doubt so as I do not see the link to mis-firing as my mileage done was only 14k+ km for a 14mth car. How do they explain the high fuel consumption and also the “pinging”. Now using Shell 98Ron still ping! Was asked to monitor.....

11 May'05 morning, crank the car and let it warm up. Juz less than 1 min, the same mis-firing occur again, engine vibration vigourously and the engine check light came up. FORCED the car which feels like a REX's engine back dealer. 1/2 way thru, the engine check light disapprear and the car slowly went back to "normal" . When reached dealer, they told me tat since the engine check light is off, they can't trace the fault code. I asked for a courtesy car and was told all courtesy cars out and the earliest tat it will be back will be next week. Shxt...., drove out of the dealer, dun wanna waste time leaving the car there. Was again asked to monitor......

13May'05 today, car mis-fire again. I use my phone to take video on the vibration, sound and engine check light, forced the car which is barely movable slowly back to the dealer. On the way back, the check light disappeared and the engine went back to normal. Upon reaching, told SA abt it and showed him the video clip. He mention tat it's mis-firing indeed. BUT, still no courtesy car for me until next week unless I wanna leave with without car for a few days. I disagreed and he proposed that they add fuel addictive and then I go fill up Mobil 98 ron petrol. This happens to 1 of their customer b4 and until 1 mth past, the owner nuber complain so far. Like tat call wat remedy!

Sorry for being long winded, anyone experience it before and wat's the remedy. The dealer said that they are still waiting for a response from the Korea side as they have no idea wat went wrong.
 

·
Registered
Joined
·
18 Posts
:( Hi

Sad to learn that you are facing the same experience as my 2003 Rio auto 1.5
I had the same problem, been in to Thomson Centre 7 times in 3 weeks.
Finally, after all the checking and changing of cylinders heads, car is better for
a week. Recent morning starts show that the same problem may be recurring.
Could be due to inferior parts used. Could you believe even the Agent has no
clue to solve this problem.

Advice : I will sell the car after 3 years and buy a Toyota. Enough of Korean
brands.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Originally posted by richardlim8@May 17 2005, 09:33 AM
:( Hi

Sad to learn that you are facing the same experience as my 2003 Rio auto 1.5
I had the same problem, been in to Thomson Centre 7 times in 3 weeks.
Finally, after all the checking and changing of cylinders heads, car is better for
a week. Recent morning starts show that the same problem may be recurring.
Could be due to inferior parts used. Could you believe even the Agent has no
clue to solve this problem.

Advice : I will sell the car after 3 years and buy a Toyota. Enough of Korean
brands.
Bro, shocked that it needs replacement for cyinders head. Major job huh? Did they change the spark plug cables, ignition coil and fuel pump before they start to replace the heads? Wat about other jobs being done b4 the head change, did they do it? So my guess it's tat they still have no clue abt wat's wrong with our cars huh? So sad...., din know the agent who are specially trained for Kia is unable to solve or probs. Sign....
 

·
Registered
Joined
·
14 Posts
Huh, a~ don't scare me leh. just started to bid coe for my new 1.5L hatchback leh. Korea car leh.... Btw, is Kia 1.5L hatchback belongs to Kia Rio 1.5L???
New bird to car issue
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Originally posted by Michelle@May 17 2005, 05:08 PM
Huh, a~ don't scare me leh. just started to bid coe for my new 1.5L hatchback leh. Korea car leh.... Btw, is Kia 1.5L hatchback belongs to Kia Rio 1.5L???
New bird to car issue
Hahahahahaa, buying a car sometimes is like lucky draw. If you get a sour lemon, there's not much you can do except to get it fixed. H/B is a 5-door version, but it's the same engine and ECU for sedan too.
 

·
Registered
Joined
·
14 Posts
Hi comparing Kia 1.5L Hatchback & Picanto. Which is better? If my coe bid fails, am going to change my mind asap before banding my head on the wall. Pls advise :wallbash:
 

·
Registered
Joined
·
18 Posts
Hi Michelle

If you have bought your Rio, you just need to monitor it carefully. I have the same
stalling problem till date, after numerous towed back trips to service centre.
Many parts were changed and guess what next week, going in for oil pump
change which will mean being carless for two days.

Just slightly two years old and loads of engine problems. It is indeed a challenge
driving this Rio, you never know when it will stall or can not even start on mornings.

Take care, Michelle

Kianomore
 

·
Registered
Joined
·
11 Posts
I got the same prob and guess what was it?... only sparkplug cables. Dont forget that u use Bush injection unit and since i got the same situation like my Volks and that i explain to them my previous experience with my old car, they discovered that the cables was leaking and was not sealed propely... since i have a new set of cables all is ok.
 

·
Registered
Joined
·
18 Posts
Hi Skyfox

Yes, they did changed my spark plugs cables and entire cylinders heads. Car ok
for a few weeks and then the symptoms of stalling are returning. Next week, back for engine oil pump change.

Any suggestions?

Thanks.

Kianomore :(
 

·
Registered
Joined
·
18 Posts
Hi Skyfox

Can you share what cables you have changed to? The dealer changed mine, I
believe the same type from the factory.

Thanks

Kianomore
 

·
Registered
Joined
·
11 Posts
I mean Bosh injection, sorry i did a typo... and they replaced the cable 1,2,3... About the misfiring part, my dad is working in a dealer for Chrysler. Lots of cars now have that kind of problem not only Kia. The result is that the engine light will turn on for nothing and once in a while u will get some jerky starting. There is nothing we can do just to reset the computer and to see next time. The more we will get electronics in our car and the more we will see those kind of problems.
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,127 Posts
This is a very easy fix..... sorry i did not see this thread.. here we go


P0300 Multiple/Random Misfire detected.
P0301 Misfire detected - Cyls. 1-4.
P0302 Misfire detected - Cyls. 1-4.
P0303 Misfire detected - Cyls. 1-4.
P0304 Misfire detected - Cyls. 1-4.


What you need to fix is change all the plugs, wires, and the 2 coils and you will good to go!!!!!! I would at first just replace plugs, wires. if misfire is still happening then get the coils.....
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
Originally posted by 1fastkia@Jun 1 2005, 09:57 PM
This is a very easy fix..... sorry i did not see this thread.. here we go
P0300 Multiple/Random Misfire detected.
P0301 Misfire detected - Cyls. 1-4.
P0302 Misfire detected - Cyls. 1-4.
P0303 Misfire detected - Cyls. 1-4.
P0304 Misfire detected - Cyls. 1-4.
What you need to fix is change all the plugs, wires, and the 2 coils and you will good to go!!!!!! I would at first just replace plugs, wires. if misfire is still happening then get the coils.....
They have changed the fuel pump, mass air flow sensor, auto lash and internal engine oil pump. So far have been driving for 3 days without any sign of mis-firing. Will monitor and if the mis-fire happens again, will ask them to replace the coil and cables. Thanks for the advice!
 
1 - 15 of 15 Posts
Top