Kia Forum banner
1 - 3 of 3 Posts

·
Registered
Kia Optima SXL 2013
Joined
·
1 Posts
Discussion Starter · #1 ·
I have my Kia Optima SXL in the shop, the turbo has failed. It has had the usual Kia failures new engine at 30,000. Steer colum plastic union. All cpu updates 120 engine point check etc.
Now let me explain this one to you. As of the above mileage, I was on the way to work when all of a sudden I started to hear a high pitch winning, I thought it was the music I was listening to. I turned of the music and found it coming from the engine on acceleration.
With this happening I immediately started looking at my dash for other indications warning lights irrational needle display. There was none.
I the checkers my mirrors only to find white smoke bellowing from the exhaust system. I nursed it to work and decided to look at the car later when work was finished. I did on inspection of the oil dip stick I found absolutely no oil apart from a couple of black oily spots on the dip stick. On touching the bottom of the stick I felt no oil it was just the feel a show of an oil stick untouched by oil. So with my wife following me we nursed the car to a Sheetz just down the road from work bought the smallest 4 quarts oil put it into the car, and headed home. Got the car into the shop the next day, told them what had happened and left it with them for to be checked out.
Later that day they called to tell me that the turbo had gone, and that there was an excessive amount of oil in the car, for which a cannot understand. They stated that’s why the turbo fail. I stated that can’t be. 1. It stared before any oil was added (which was the first time I had ever had to do). 2. There was no oil in the engine, before I added a small 4 quart bottle. Now the y are telling us that the turbo will not be replaced under warranty due to to much oil in the car. They can’t explain why or how an engine can go from no oil to , to much oil. Even although the issue happened before the oil wash added. The turbo to be fitted will beat a cost of $3900. We have tried contacting KIA USA , with no resolution. ANYONE ELSE HAD THIS .?.
 

·
Moderator
99 Kia Elan 1.8L
Joined
·
12,095 Posts

·
Registered
2011 Forte SX 2.4L (thankfully MPI) A/T 144K miles
Joined
·
1,612 Posts
Waste of time to look for something or someone else to blame. Your mistake - just fork over the cash.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top