Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Everybody,
This is my first post at this forum, greetings to all,

I have Kia Ceed 2008 1.4 DOHC (Petrol+LPG) with 160.000km on. This problem only happens on cold start, when the car is not driven for 1-2 days.
When I start the car the engine is working very bad like its doesn't have enough power, or pulling enough fuel, and the car doesn't react on pressing the gas pedal. The rpms are moving up and down all the time, although the car is at idle.
This happens for maybe 1-2 minutes at startup, at cold start. After that the car is working normally all the day. There is no error on the dashboard. I have changed spark plugs, I have the computer reprogrammed, clean the fuel system with additives, check LPG leakings to the petrol system, but nothing changes. I have the car checked at 5 garages and everyone says different diagnostics.
Thanks in advance,
 

·
Registered
Joined
·
1 Posts
Did you find a solution? Just happened the same, same vintage, same engine, 180000km on clock. I've changed spark plugs but didn't do the trick
 

·
Registered
Joined
·
1,872 Posts
Did you find a solution? Just happened the same, same vintage, same engine, 180000km on clock. I've changed spark plugs but didn't do the trick
Where are you located, as not familiar with the LPG/petrol here in the NA market.
A LONG time ago I had the misfortune to have to work on an LPG conversion for no start/ poor run...Turned out to be a problem in the switch valve (gas to LPG) AND the LPG regulator.
Are you starting on "Petrol" or trying to start on LPG?
 
1 - 3 of 3 Posts
Top