Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
the lights got left on on our Sedona after charging it we have issues. The A/C wont engage and even on the cool setting the unit blows warm. Idle low causing stall of engine.

I checked the A/C relay it is good.

Thanks Scott
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,923 Posts
Computers and micro-computer (found in cars) do not like low voltage and can be corrupted by that. I'd suggest you disconnect the battery...wait 5 minutes...then reconnect it. This is similar to the reset button on your home computer.
Be prepaired to find some temporary unusual things going on... The radio will loose it's presets, the clock will have to be reset, the engine will run strange and the tranny will shift "funny"... The car will need to re-learn how you drive and the best air/fuel mixture mixture and shift points...If you understand what is going on it won't upset you while it's learning... The HVAC (heat and AC) also has a micro-controller and it's probably "lost"...
After a couple of miles (stop and go, highway,etc) things should iron themselves out.
Dave
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Is the A/C Micro in the Main computer? It is the only issue not self correcting.
Thanks
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,923 Posts
That would be a the HVAC controller so you might get away with pulling the fuses that feed this micro..
Dave
 
1 - 6 of 6 Posts
Top