Kia Forum banner

1 - 7 of 7 Posts

·
Registered
Kia Ceed 2013
Joined
·
3 Posts
Discussion Starter #1
Hi for all. Can anyone tell me why my ISG don't want to work. :((( Really is necessary a lot of conditions? Belt closed, engine hot, no error in computer, no air conditioning, good battery. And...... nothing! In 5 month only once i see this ISG working ! Please help me with advice. Thanks
 

·
Registered
Kia Ceed 2013
Joined
·
3 Posts
Discussion Starter #2
KIA Cee'D 2013 1.6 CRDI ISG deactivated

Can anyone tell me what can i do to enable my ISG (AutoStop). For my car is permanently deactivated or is something he does not like! In 5 month since I have this car, I saw him working only once. :(I think I'm doing everything what he need, I put my belt before starting the engine, I drive very very slowly, I got out of gear and released the clutch pedal, I have no errors at DPF, I expected the engine to be hot, I stopped the air conditioning, the battery was ok. And ... he still does not want it! Has anyone ever met this problem? maybe this is a NASA device ..... ?????? Thanks anticipated.
 

·
Registered
Cee'd 2 CRDi(126)
Joined
·
63 Posts
If your journeys are short and without much in gear coasting the battery is probably insufficiently charged. This is my experience in almost six years of ownership. Try charging the battery to full. It might take 24 hours for ISG to start working after charging.
 

·
Registered
Cee'd 2013
Joined
·
4 Posts
The battery will not be sufficiently charged if you only drive under 10-15 minute trips.

One of numerous temperature sensor might be faulty, leading to the car thinking the engine or outside temp. being too low.

Also there can be a fault with the clutch sensor, for example the car might think the clutch is pressed all the time. Does your cruise control work normally?

And then there could be a problem with any kind of gear sensor, for example the car thinks it is in gear all the time. Does the car suggest what gear to shift up to correctly?

Have you taken it in for professional diagnosis?

Sent from my Mi A1 using Tapatalk
 

·
Registered
Kia Ceed 2013
Joined
·
3 Posts
Discussion Starter #5
Thanks a lot for all. Yes, everything you have suggested seems to be correct. My trips is only to work and back in town about 8 km. Maybe the battery does not grab to fully charge. So in the last two nights I put on a loader to try to load it 100%. Then I'll try to see ... if it still works. I'll be back in a few days with new details. Thank you again for your help!
 

·
Registered
Kia Ceed 1.6 GDI 2013,Mazda 6 2.0i 2013
Joined
·
4 Posts
up not alone,my car doing same....and i am happy :)...i wish i can easily deactivate it on my another car-mazda
 
1 - 7 of 7 Posts
Top