Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
For the first week or so that I had my EX, I used the iPod cable that came with my nano plugged into the USB port. On the UVO screen, the album artwork showed up along with song name and artist. I could also use the sterring wheel to control the iPod.

Now when I plug my iPod in, the UVO screen says that there is no media plugged in. Sometimes it says that it is reading the media, then it comes back saying it has failed.

The only thing I have done different since the first week, is that I set up my blackberry for use with bluetooth in the vehicle.

Any thoughts on this?

Thanks
 

·
Registered
2017 Sorento SX+ V6 AWD - 2016 SX+ V6 AWD (crashed) - 2014 SX V6 AWD (sold) - 2011 EX V6 AWD (sold)
Joined
·
369 Posts
Deplug your iPod, hard reset it, plug again and it should work.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks Goose ! Seemed to work......

Weird thing is, I went and got the KIA cable from the dealer, plugged th iPod in and it plays music. But the UVO screen just says "AUX Connected". Doesn't show any info on the screen about the song, artist or artwork. AND, the steering wheel controls do not work.

I thought the KIA cable would allow you to choose either AUX or USB, but it doesn't.

Weird.

Thanks for the tip on the hard reboot. That will be my method !
 

·
Registered
2017 Sorento SX+ V6 AWD - 2016 SX+ V6 AWD (crashed) - 2014 SX V6 AWD (sold) - 2011 EX V6 AWD (sold)
Joined
·
369 Posts
Thanks Goose ! Seemed to work......

Weird thing is, I went and got the KIA cable from the dealer, plugged th iPod in and it plays music. But the UVO screen just says "AUX Connected". Doesn't show any info on the screen about the song, artist or artwork. AND, the steering wheel controls do not work.

I thought the KIA cable would allow you to choose either AUX or USB, but it doesn't.

Weird.

Thanks for the tip on the hard reboot. That will be my method !
Your're welcome !

For what I know the iPod Kia cable is not needed anymore since 2014 models. Just need the original iPod cable and you should get all information (artworks, titles, etc.) and controls (on the radio and steering wheels).
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Well, after working for a day or two, back to the same issue......

Plug the iPod in using the white iPod cable, and the UVO doesn't recognize it. Won't even charge.

If I use the KIA iPod cable, UVO only says "Aux Connected" and none of the controls work.

I have tried hard resetting the iPod, but that is not working now either.....

Even tried with different iPods and different cables.

Quite annoying.......
 

·
Registered
2014 Sorento LX
Joined
·
18 Posts
See this post:

http://www.kia-forums.com/2014-sorento-forum/94665-uvo-my-2014-spotify.html#post556410

My opinion, you want the Aux method in the end regardless of how much the UVO brochure talks about iPod integration - it's crap.

Well, after working for a day or two, back to the same issue......

Plug the iPod in using the white iPod cable, and the UVO doesn't recognize it. Won't even charge.

If I use the KIA iPod cable, UVO only says "Aux Connected" and none of the controls work.

I have tried hard resetting the iPod, but that is not working now either.....

Even tried with different iPods and different cables.

Quite annoying.......
 
1 - 6 of 6 Posts
Top