Kia Forum banner

1 - 10 of 10 Posts

·
Registered
2012 SX
Joined
·
76 Posts
Discussion Starter #1
A share if you will . . . after installing iOS6 on iphone the syncing/music play between Sportage and phone is improved. Used to be when I first hooked the phone up the music would only play about 15-30 seconds and stop. It would require me to go into the iphone and reselected the cord connection as the source (between bluetooth and cord connection). And I didn't want to turn off the option of bluetooth and loose the phone functionality portion.

Also, it seemed every time I connected the phone via the cord it would start playing the first song in my playlist by alphabetical order, no matter the song that was being listened to prior to disconnecting/turning the Sportage off. Both issues are gone with iOS6. I don't have to reselect anymore when starting out-it just keeps playing. And it remembers the last song played. Not earth-shattering, but wanted to pass on to anyone who might experience this kind of thing and hasn't yet updated their iPhone.
 

·
Registered
2011 AWD Sportage SX
Joined
·
926 Posts
I never had a problem with this with my old iphone 3gs and have gone through various ios updates and play non stop. I got the new iphone 5 with the ios 6 and will test it out when I upload some music.. hope the nav would show what song is playing on the iphone.. Did you notice if the song tite appears on the nav with the ios 6?
 

·
Registered
2011 Kia Sportage SX w/ Premium Package & Nav
Joined
·
194 Posts
I had very sporadic Bluetooth connectivity issues before. Nothing major. Use Bluetooth to stream Spotify and other audio stuff to oem nav. Every so often I would have to turn phone Bluetooth on and off for it to connect to car. Rare so wasnt an issue...

I also just got my new iPhone 5 w/ iOS 6. Hardware is 2x as fast and seems to "link" via Bluetooth quicker now and with 4G/LTE service streaming music seems quicker in regards to buffering etc.

All in all the new hardware and OS works great for me and my 2011 SX w/ oem nav head unit. It may not be revolutionary new hardware or software, but it's a welcome upgrade from my old iPhone 4.

ps... Super impressed w/ Siri. Must faster processing now and has been more useful than I imagined. Especially when using it hands free in the sportage! Sending texts has never been easier and safer ;-)
 

·
Registered
2012 Sportage SX CDN
Joined
·
29 Posts
Hi All,

I have been having quite the opposite experience with my iPhone 4 ( IOS 5 and 6 ) and 2012 SX NAV. Upon initial installation when I first picked up the car, everything worked great. Some time after one of the IOS5 updates I started loosing services.

First I lost the contacts sync, everything else worked fine. Then when I realized my contacts were not syncing anymore, and started debugging I started loosing everything
else.

Now I have lost 'redial/callers list' as well as contacts. Now my NAV unit shows up as CK5050P instead of SPORTAGE on Bluetooth discovery. However streaming audio playback in unaffected.

What I have done at this point:

Reset the NAV unit Bluetooth connection in the 'Advanced Settings' in the 'Phone' menu.
Turned ON/OFF 'syn Contacts

On the iPhone, in Bluetooth Properties, I have turned ON/OFF all options in this sub menu. No difference.

Does anyone have any solutions, fixes or other menus on the iPhone that I migh thave missed?

Thanks
 

·
Registered
2011 AWD Sportage SX
Joined
·
926 Posts
Have you tried it with another iphone and see if its still doing the same thing.... You could try resetting the nav??? Havent done it for a long time... but when I disconnected my battery terminals for a few minutes and reconnected them back, I had to set my stations and clock all over again.. but I dont remember if I had to repair my phones or not.... Doesnt hurt to try.
 

·
Registered
2011 Kia Sportage SX w/ Premium Package & Nav
Joined
·
194 Posts
I'm sure you did this, but just in case: in the nav head units settings go to "connections" or "pairings" (can remember what it's called) and delete your phone. This removes your address book and other phone related settings from the car. Then, try repairing and see if that helps.

My unit shows something other than "sportage" for a split second when pairing. But, it then says "sportage" as the device name once paired... If it sticks on some other device name it could be the head unit??

Ps... Do you jailbreak your iPhone? I ask for a specific reason. When jail breaking iOS it loads (sometimes) a modified Bluetooth software stack to the phone which overrides the default iOS version. This could be the issue as well. I noticed more quirks when my iPhone was jail broken in regards to Bluetooth. FYI. Now that my new iPhone 5 is running fresh software w/o a jailbreak installed, I've had no issues with Bluetooth connectivity.
 

·
Registered
2011 AWD Sportage SX
Joined
·
926 Posts
Ps... Do you jailbreak your iPhone? I ask for a specific reason. When jail breaking iOS it loads (sometimes) a modified Bluetooth software stack to the phone which overrides the default iOS version. FYI. Now that my new iPhone 5 is running fresh software w/o a jailbreak installed, I've had no issues with Bluetooth connectivity.
Hes on IOS 6 but has had the same problem since IOS 5. I dont think jailbreaking is the issue since IOS6 doesnt have a jailbreak yet :(.

@BidDzl: Yeah, follow SneakyMe's post about making sure your disconnected (connection button) and unpair (pairing button), Im not sure if the button are named that either (shorterm memory : ) ). Then try to repair (car has to be in Park to allow to add a new phone). And if that fails.... try my battery post.. see if that works... Goodlcuk.
 

·
Registered
2012 SX
Joined
·
76 Posts
Discussion Starter #8
Too earlier poster- I have not noticed that the song info shows on nav screen. I'm actually thinking when using nav of just using the iPhone-I'm on that likes the new maps app and potential with nav on that. The 3d view is nice. I just know that overall it's a much better integration between phone and Sportage. No more fiddling, it's plug-n-play. And I didn't mention-using iPhone 4s.
 

·
Registered
2012 Black Cherry Sportage LX (Totaled), 2017 Mineral Silver Sportage LX
Joined
·
68 Posts
I agree with OP. It's great not having to go in and manually select Dock Connector anymore. However for the first few days after upgrading to iOS6, was was getting frequent Comm Errors, although it hasn't done it for the past 2 days so maybe it resolved itself.
 

·
Registered
MY 2012 Kia Sportage Platinum
Joined
·
6 Posts
Is anyone able to tell me if the iphone 5 with lighting to dock connector cable works with a non Nav unit
 
1 - 10 of 10 Posts
Top