Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Titanium 2013 Soul 4U 2.4 Litre Coupe Mantronic Transmission Back Up Camera & UVO
Joined
·
94 Posts
Discussion Starter #1
Anyone else out there having connection issues between an iPhone 4S, and the 2012 Optima?
 

·
Registered
'12 Optima EX Premium
Joined
·
15 Posts
The only issue that I have is that occasionally the UVO system will not connect. I'd have to delete the phone and then add it back in. That can be a PITA when you had planned to get in the car and go.

Other than that it's worked pretty good for me
 

·
Registered
Titanium 2013 Soul 4U 2.4 Litre Coupe Mantronic Transmission Back Up Camera & UVO
Joined
·
94 Posts
Discussion Starter #3
THANK YOU! That is the issue I have. It looks like it is connected on the Radio, but on the Handset it is not.
 

·
Registered
'12 Optima EX Premium
Joined
·
15 Posts
I'm hoping some future UVO firmware update will take care of this issue. It happens so infrequently that trying to schedule a service call while it's out is difficult, if not impossible.

Another minor issue that has been addressed, if you've experienced it is the drivers seat feels like it's shifting during cornering or turns. KIA has a TSB out on it.

Good Luck with the car. I'm loving it more with each drive
 

·
Registered
Titanium 2013 Soul 4U 2.4 Litre Coupe Mantronic Transmission Back Up Camera & UVO
Joined
·
94 Posts
Discussion Starter #5
I have not noticed any issue with the Drivers Seat. How do I find out the version of the UVO Firmware installed, and the most current version?
 
1 - 6 of 6 Posts
Top