Kia Forum banner

1 - 17 of 17 Posts

·
Registered
2012 Sportage SX CDN
Joined
·
29 Posts
Discussion Starter #1
Does not work folks...sorry.

Received it yesterday and once I plugged in the Kia cable with Apples adapter on it, the iPhone 5 started cycling through songs uncontrollably. It never stated playing any of them just cycling through everything in my library. Worse, once I unplugged the cable the iPhone continued to cycle, I had to restart the iPhone to stop it. It DOES charge the phone, if you willing to watch your display cycle through all your media :) Streaming audio and a 12V USB adapter are what will need to be used going forward, or until Kia upgrades their cable.
 

·
Registered
2011 Sportage SX
Joined
·
979 Posts
That's odd, there's a thread in the MacRumors website discussing this topic and owners of a Genesis and Elantra have reported sucess.
 

·
Registered
2012 Sportage SX FWD
Joined
·
354 Posts
have you tried only using the regular 30pin ADAPTER cable that comes with your iphone? i'm pretty sure that KIA adapter cable is for non-UVO systems. I have used the regular cable with my iPod 5G (video, 30GB, black) and it works fine, albeit slowly. It takes a while to browse through the library and loads slowly, but it works and charges fine.
 

·
Registered
2011 Sportage SX
Joined
·
979 Posts
I just tried my 30-pin lightning adapter with my iPhone5 on my NAV HU, it works fine. I was able to switch songs, pick playlists, scan through my song library without any problems. Maybe you have a bad adapter?



It seems as though the annoyance where the sound would cut out once the phone is connected to the HU via Bluetooth is also gone. I had a song playing when I received the Bluetooth connection confirmation on the screen and the song never stopped.
 

·
Registered
2012 Sportage SX CDN
Joined
·
29 Posts
Discussion Starter #5
I just tried my 30-pin lightning adapter with my iPhone5 on my NAV HU, it works fine. I was able to switch songs, pick playlists, scan through my song library without any problems. Maybe you have a bad adapter?

Interesting could you give me the specifics of your car for comparison. I have the following :

2012 SX NAV CDN
Kia OEM iPhone Adaptor ( short black ,came with car )
No updates to the NAV HU
iPhone 5 30Gb IOS 6.0
 

·
Registered
2012 Sportage SX AWD
Joined
·
42 Posts
It works perfectly for me also, just the same as it did for my iPhone 3Gs without the 30-pin lightning adapter. I have the 2012 SX with Nav.
I am using the adapter with the Kia cable
 

·
Registered
2011 Sportage SX
Joined
·
979 Posts
I just tried my 30-pin lightning adapter with my iPhone5 on my NAV HU, it works fine. I was able to switch songs, pick playlists, scan through my song library without any problems. Maybe you have a bad adapter?

Interesting could you give me the specifics of your car for comparison. I have the following :

2012 SX NAV CDN
Kia OEM iPhone Adaptor ( short black ,came with car )
No updates to the NAV HU
iPhone 5 30Gb IOS 6.0
2011 SX NAV CDN
KIA OEM iPhone adapter
No updates to the NAV HU
iPhone 5 32GB IOS 6.0.1
 

·
Registered
2011 Kia Sportage EX
Joined
·
26 Posts
My apple adapter also works fine with the kia cable. There is a small issue, but it doesn't bother me as long as it works. I have had to reconnect several times when I play the pandora app...haven't tried it with itunes yet. However, I don't have UVO or navigation.
 

·
Registered
2012 Sportage SX CDN
Joined
·
29 Posts
Discussion Starter #9
Replaced Adapter, same issue, iPhone Next ?

Well, I got the adapter replaced, same issue, any other ideas out there ? I have attached a photo of the Kia Cable and adapter attached, just in case my cable turns out to be a different vintage. I also updated to IOS 6.01
 

Attachments

·
Registered
2K13 Forte SX Lux yada yada yada...
Joined
·
151 Posts
@BigDzl

If all you're trying to do is play music from your iphone, then why not forget the cable all together and stream via Bluetooth? It's quick, efficient, and sounds practically the same...
 

·
Registered
2012 Sportage SX CDN
Joined
·
29 Posts
Discussion Starter #12
Solution

I borrowed a friends iPhone 5 and there were no problems connecting his device. So the problem is with the iPhone itself. Hardware or Software ?

A complete Factory Reset and Restore for iCloud, did no solve the problem either, however it ultimately led me to the solution. I noticed that the restore put my music back a well. That got me thinking about the music itself having some bizarre problem with the new connector.

Deleting the tracks via iTunes and putting them back made no difference. However I finally found another way to delete media and apps if necessary locally on the device itself. Goto [General][Usage] and select [Music] deleting add data stored there. This wipes also out all the music stored on your device, just not selectively.

Once I reconnected, the iPhone was stable, then I added some tracks back and everything worked perfectly.

Just to clarify, initially connecting to anything with the 8pin connector never caused any issues with the music, connecting to several devices via bluetooth worked fine with all the tracks that were initially stored on the device as well.

WEIRD!!!
 

·
Registered
2013 Kia Sportage T-GDI, 2007 Toyota FJ Cruiser, 1992 Toyota Land Cruiser FJ80
Joined
·
8 Posts
Im just using the same white cable that came with my iphone5 and everything works just fine.
 

·
Registered
2013 Optima EX, 2013 Rio EX
Joined
·
11 Posts
Just picked up my Optima last night. I have a non UVO head unit. When I plug my standard Apple cable into the USB port I get the charging cycling on and off. My fiancee has a Rio with UVO and her's works just fine. For what it's worth my phone used to work in her car and does the charging cycling now.

Have people had success using the 30pin to Lightning adapter with the stock Kia cable in a non UVO car?

Also, does the non UVO head unit support bluetooth streaming?
 

·
Registered
Joined
·
7 Posts
Just picked up my Optima last night. I have a non UVO head unit. When I plug my standard Apple cable into the USB port I get the charging cycling on and off. My fiancee has a Rio with UVO and her's works just fine. For what it's worth my phone used to work in her car and does the charging cycling now.

Have people had success using the 30pin to Lightning adapter with the stock Kia cable in a non UVO car?

Also, does the non UVO head unit support bluetooth streaming?
I have a 2013 Forte 5 door...had the Kia adapter cord for my ipod classic, but just got an iphone 5 a week or two ago. I tried to plug in to charge with just the regular Apple cable and it kept doing a charging cycle, off/on/off/on...

Was wondering if the 30 pin adapter would work so I could switch between iPod and phone (depending on what I had handy that day). Sounds like the pin adapter might be the answer I need...just wonder why the car won't read the Apple connector though (for charging purposes). But if the 30 pin will allow me to charge and listen to music, that's fine too.
 

·
Registered
2012 Kia Sportage LX
Joined
·
101 Posts
I have an iPhone 5 with the adapter. Works good. 1/20 plugs I will get a weird no music error, probably because my fiancée unplugs the adapter to use her iPhone 4 and doesnt fully plug it back together. (It fits a little snug). Other than that, it charges, plays, allows you to use the display to navigate through your phone. Good buy, but like I stated in a previous post similar to yours on here, GET THE APPLE ADAPTER. I've been down the rabbit hole of trying to get the $5 chinese shit to work, it doesn't save yourself the headache.
 
1 - 17 of 17 Posts
Top