Kia Forum banner

1 - 2 of 2 Posts

·
Registered
2012, Picanto , Auto, 1.2L
Joined
·
1 Posts
Discussion Starter #1
Hi

Strange problem! I replaced the aux/usb ports in my 2012 Picanto. This involved removing the gear knob and centre console.

I drove the car soon after and it selected the wrong gear, like it was starting in second gear and then on the motorway it felt like 3rd gear whilst at 100kph, the revs were 4500 as opposed to the usual 3000.

I took off the gear knob and centre console again and put them back on but didn't clip the centre console back on. Gears were then fine. This has been the general theme for 2 weeks now, clip the console down and shortly after the gears go wrong again. Lift the console slightly and sometimes they are instantly better.

Is there anything under that console I could trap that would cause this? A loose connection that may have occured when taking the console out? Something to do with removing the gear knob or just all coincidences?

Thanks in advance!
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 2013 BMW K1600 GTL
Joined
·
11,129 Posts
Hi

Strange problem! I replaced the aux/usb ports in my 2012 Picanto. This involved removing the gear knob and centre console.

I drove the car soon after and it selected the wrong gear, like it was starting in second gear and then on the motorway it felt like 3rd gear whilst at 100kph, the revs were 4500 as opposed to the usual 3000.

I took off the gear knob and centre console again and put them back on but didn't clip the centre console back on. Gears were then fine. This has been the general theme for 2 weeks now, clip the console down and shortly after the gears go wrong again. Lift the console slightly and sometimes they are instantly better.

Is there anything under that console I could trap that would cause this? A loose connection that may have occured when taking the console out? Something to do with removing the gear knob or just all coincidences?

Thanks in advance!
Using the below link, please add location and vehicle (year & model) to your User Account/Profile

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD


UPDATE: Vehicle Information


Forum Rules


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 
1 - 2 of 2 Posts
Top