Kia Forum banner

1 - 2 of 2 Posts

·
Registered
2000 Kia Sephia
Joined
·
19 Posts
Discussion Starter #1
I was needing a car. I was in a bad place. I relearned how to work on my own car with this one. I replaced my horn, washer pump, buffed her out, changed the stereo and speakers, changed the rear brakes, changed the thermostat and flushed out the system, changed the driver outside door handle, and I also butchered the dashboard and put a cover on it. I love this car. My latest dilemma is a grinding noise coming from the left side of the engine compartment. I was told that I need to replace the ignition coils and the idle valve. Could that have to something to do with it? It just started a week ago. She still runs fine, it's just that whining noise bugs me. Someone help me please?
 

·
Registered
1985 Subaru Loyale (wagon), 2000 Kia Sephia (sedan), and 1969 Mercury Comet (coupé)
Joined
·
2,828 Posts
These Sephias are Awesome cars, but made with cheapo plastics and thin wiring, which are their achilles heel, somehow.

Let me ask you a Question regarding yours: Is Lit the "Check Engine" warning light, at the instrument cluster?

If there is really a problem with one of the two ignition coils, said light not only should be lit, but blinking, as it is a major fail; but since you described that your Sephia runs and drives fine, I don't believe that there is a problem with the coil, nor that such a thing could have something to do with the grinding noise that you report.

I Kindly suggest you to check for worn brake pads / discs, and wear on the belts, also a fail that is common, is the main pulley's rubber, that shrinks with age, making a screech sound, that starts softly, and grows with usage.

Kind Regards.
 
1 - 2 of 2 Posts
Top