Kia Forum banner

1 - 3 of 3 Posts

·
Registered
2007 Kia Sportage EX Luxury
Joined
·
8 Posts
Discussion Starter #1 (Edited)
I noticed that hot air has been coming out the driver vent, the round vent above it, and the two center vents in my 2007 Kia Sportage even though the heat and A/C are turned off. Since my Kia was warm from being in the sun, I turned on the air conditioner and the air was cold as it should be. When I turned off the A/C, nothing was coming out of the vents.

I have also noticed that when I turn the heat or A/C off, there are a lot of clicking noises.

I just bought my Sportage and it is under an extended warranty, so I can bring it to the dealer if I need to. However, if they find nothing wrong with it, I have to pay because they looked at it.

Lately, no air has been coming out of the vents when the climate controls are off. However, heat comes out of the vents when I have the heat on floor.
 

·
Registered
2008 Kia Sportage 2.0; 2000 F150 Lariat 4X4; 2006 Chevy Trailblazer
Joined
·
57 Posts
It is your mode actuator doing this. Probably has a linkage popped out. Look under dash, by acclerator pedal towards the radio. You will see a big cam turned by a little box with tiny rods attached to it. Sometimes, the rods pop out of place. A dealer will cahrge you 105.00 for the part, plus labor, and not replace anything, just pop the rod back in place. Take a look, and you will see what I am talking about. My 08 does it about once every 4-5 months.
 

·
Registered
Joined
·
2 Posts
It is your mode actuator doing this. Probably has a linkage popped out. Look under dash, by acclerator pedal towards the radio. You will see a big cam turned by a little box with tiny rods attached to it. Sometimes, the rods pop out of place. A dealer will cahrge you 105.00 for the part, plus labor, and not replace anything, just pop the rod back in place. Take a look, and you will see what I am talking about. My 08 does it about once every 4-5 months.
Tinman 1 is it possible to attach a photo or a small video to see where exactly is located the actuator-cam and the rod that needs to be inserted back into the groove? Thank you!
 
1 - 3 of 3 Posts
Top