Kia Forum banner

1 - 11 of 11 Posts

·
Registered
2012 Kia Sportage LX
Joined
·
101 Posts
Discussion Starter #1
Hey guys and/or gals,
I have a weird issue arising with my HID lights.
I installed both HID lights and they worked perfectly for a month with no problems/ no flicker.
Just on Friday I got in my car and started it up turned the headlights on and both cut on and one cut back off. If I put my car in park and press the brake sometimes the light comes back on, and then I put it in reverse and it goes out. I really havent found a solid pattern to the problem.
I have already switched the ballast and the bulbs are not an issue.
Do you think this is a ballast issue or that I need a relay harness? I would think it's a ballast if they worked fine for a month and then started messing up but what do I know I was already stupid enough to buy a cheap HID set, which is probably the first problem here.
Thanks in advance.
 

·
Registered
Cerato S Hatch Auto
Joined
·
1,236 Posts
Seen some reports of the HV causing problems to the rest of the electronics. Seems that HID is the latest fad; I've covered many miles at night with just POL (plain old lights) and halogens.
 

·
Registered
2011 AWD Sportage SX
Joined
·
926 Posts
In my opinion you have a faulty ballast. My old HID kit had a relay harness and once in a while I would have one light turn on while the other doesnt. I would have to turn the car off and back on and play with the switch and eventually both would fire up. After a year, I thought I blew a bulb but after installing a new one it was still not working. Bought a different brand HID kit and installed them and both fired right away.

So its most likely a faulty ballast if they worked fine before and one suddenly starts to act up. Its just a sign that the ballast is going to go. My opinion, replace the ballast or buy a different brand. If the harness is the problem and the connections are secure then both your lights will fail to turn and not just one.
 

·
Registered
2012 Kia Sportage LX
Joined
·
101 Posts
Discussion Starter #4
I do not have a relay harness currently. If this ballast replacement doesn't help then I will get some relay harnesses. Luckily the buyer I bought from has a 2 year replacement warranty if anything breaks but it wont be worth the hassel if this keeps arising.
 

·
Registered
2011 AWD Sportage SX
Joined
·
926 Posts
I doubt the relay harness will help. Do you have the warning cancellation installed also? When you switched the ballasts has it happened again? If so, same light go out or where the one with the same ballast? Im still thinking its a faulty ballast. Which HID set and brand did you get?
 

·
Registered
2011 AWD Sportage SX
Joined
·
926 Posts
for foglights I would definitely use a wire harness as the stock wiring has a higher change or short circuiting since the stock foglight bulbs are only rated around 27watts its not designed to power a 35 watt ballast. Headlights is pretty much preference I had no problems with both connections, just the ballast.
 

·
Registered
2012 Kia Sportage LX
Joined
·
101 Posts
Discussion Starter #8
The ballast is on the way. I also ordered 5000k bulbs because I felt the 6000k were a little too blue for my taste. Hopefully this will do the trick, if not ill get the relay. Any recommendations on a relay?
 

·
Registered
2012 Kia Sportage LX
Joined
·
101 Posts
Discussion Starter #9
I replaced the ballast last night and installed 5000k bulbs instead of the 6000k I originally had. Everything is back to normal, and hopefully stays that way. However, now I am constantly looking to see if they are working. It's annoying. I have a 400watt max amp hooked up to my subwoofer without a compositor. Before the ballast went out I did NOT notice any dimming when using the subwoofer at high volume, but do you think the two could be related? I didn't purchase a compositor because I talked to someone who said 400watt max isn't enough to worry about.
Thanks
 

·
Registered
2011 AWD Sportage SX
Joined
·
926 Posts
Do you mean a capacitor? But no its not really needed for a 400watt amp.
 
1 - 11 of 11 Posts
Top