Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hey guys, noob here. I got this Sportage really cheap, its only got 100k on it, and seems to run great.

I bought it from a guy that has put all sorts of money into it (engine wiring harness, injectors, computer, plugs, wires, fuel pump and relay, tires, etc.) He took it to a mechanic and they said there was no power going to the fuel pump. I towed it home and noticed that they had rigged a side post battery in there with wood screws so I replaced the terminals and put a proper top post in there, but haven't had any issues starting it over the last 7 days????cranks right up every night and every morning.........maybe it will happen down the line, not sure but if anyone has seen this let me know because I don't see any issues much less know if I should even be looking for a problem.:confused:

So the other thing is the blower motor will not come on. None of the speeds work, all the fuses are good, I haven't really pulled the fan out, checked for power, or anything like that, but I figured you guys may have some insight on that.

Finally (sorry for writing a book) The sunroof track seems to be sitting in the headliner, not attached to anything. What holds that thing up? (screws, clips, glue) I don't want to just rip the headliner out without being prepared.



99 Sportage EX 4x4
 

·
Registered
Joined
·
2,221 Posts
Hey guys, noob here. I got this Sportage really cheap, its only got 100k on it, and seems to run great.

I bought it from a guy that has put all sorts of money into it (engine wiring harness, injectors, computer, plugs, wires, fuel pump and relay, tires, etc.) He took it to a mechanic and they said there was no power going to the fuel pump. I towed it home and noticed that they had rigged a side post battery in there with wood screws so I replaced the terminals and put a proper top post in there, but haven't had any issues starting it over the last 7 days????cranks right up every night and every morning.........maybe it will happen down the line, not sure but if anyone has seen this let me know because I don't see any issues much less know if I should even be looking for a problem.:confused:
...
So the other thing is the blower motor will not come on. None of the speeds work, all the fuses are good, I haven't really pulled the fan out, checked for power, or anything like that, but I figured you guys may have some insight on that.
...

99 Sportage EX 4x4
Greetings,

Congrats on your purchase.

re: Battery - if no issues, I would just verify the battery terminals & ground points are clean, the (neg. bat. tray <-> engine) ground strap is in good condition and clean, the battery holder bar / tray is keeping the battery in-place securely, and call it all good,

re: blower motor - the blower selector switch provides a (-12v) ground path -> the blower resistor, depending on setting. The blower motor has a hot (+12v) feed, supplied from the fuse in the passenger compartment fuse panel, as least on the North American (US) Sporty here.

I'd check the fuse, drop and check for +12volt hot feed at the blower connector, then proceed to back-trace negative from the blower -> to the blower resistor -> to the blower switch -> to the negative ground point.. The negative ground point is located (behind) the passenger cabin fuse panel on the Sporty here.

re: Sunroof / headliner, can't help w/ that, no sunroof here. (IIRC the headliner here is perimeter-secured, w/ plastic button inserts..)

Happy Holidays,
GottaCruise
 
1 - 2 of 2 Posts
Top