Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 1999 kia sephia with 140,000 miles on it and at about 95,000 i had the Catalytic Converter replaced on it. The car now has trouble accelerating and the check engine light blinks. Could this be another Catalytic Converter gone bad or is there something else? Should I remove the Catalytic Converter, or can I buy an aftermarket one and if so which one.

Thanks
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,127 Posts
i am betting its the plug wires..
 

·
Registered
Joined
·
10 Posts
it could be the plugs but i would look into replacing the oxygen sensors ( o2 sonsors) thats probably the problem once they go bad the computer doesn't know exactly how much air it realy is getting.
 

·
Registered
Joined
·
126 Posts
Dear Kia owner, I would bring the car to the dealer or a good garage and have it checked with a scan tool. This should give out codes that an expert can interpret better than you or I. It will probably save time and money in the long run. speedster1
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,127 Posts
or go to advanced auto and let them scan it for FREE.. dont go to a shop and pay at least 25 bucks for them to scan when the mentioned above parts store does it for free..
also a bad 02 sensor would not cause this...
it will be a misfire code.... thus replace the plug WIRES the plugs will not cause a blinking cel unless you just replaced them and have the wrong gap applied.
 
1 - 5 of 5 Posts
Top