Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
Our 7 month old GS has just developed a handbrake problem. It used to come on fully with 3- 4 clicks of the handbrake lever. It now stuggles to fully apply even at 7 clicks.

On investigation, by removing the circular pad in the base of the cup holder at the rear of the handbrake console you can see the handbrake adjuster mechanism. There are two separate cables to the rear wheels. On pulling the lever, rather than both cable being pulled equally, the left-hand cable travels twice as far as the right ie it appears that only the left-hand brake is working.

Not had chance to jack it up and check out the brakes yet but wondered if anyone else had experienced this ?
 

·
Registered
Joined
·
14 Posts
my car is about 1 month old and th handbrake is being pull higher and higher day afte each day.!

But i will be going to inform the technician about this when i service my car next month ..!

Hope mine is not as bad as yours..!


Best,
Limhouse
 

·
Registered
Joined
·
67 Posts
Discussion Starter #4
I agree its a warranty issue. From experience though I don't have much confidence in dealers and since I'm used to doing my own servicing I like to find out what's wrong myself first if poss.
 

·
Registered
Joined
·
89 Posts
My handbrake has a different problem. The ratchet is slipping at the half-way point. I went to my dealer for repair under warranty but they did not have the part in stock. Hopefully they will sort it out soon, as it affects my business.
 
1 - 5 of 5 Posts
Top