Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Sedona
Joined
·
2 Posts
Discussion Starter #1
I have been getting some shudder occasionally when at about 40 mph. but varies. letting off gas usually makes it go away. seems there are extra bumps in the road other times. no misfire codes. but running lean codes. recently replaced passenger cv shaft which made the car run much better. When doing front brakes i noticed I get some lateral movement in the bearing when moving the shaft. ??
 

·
Registered
Joined
·
44 Posts
When you replaced the front passenger side half shaft, did you also replace the intermediate shaft and bearing that connects to the transaxle?

Service manual says to separate axle at transaxle, but parts stores only sell half shaft. How does the half shaft separate from the intermediate shaft. Same type of connection?

Sorry for all the questions but I need to do this soon before taking a trip this summer. I've heard some noise up front that seem to be related to rotating parts in the drive train. Occasionally when I slow to a stop I hear a groan that sounds like a worn bearing. If seems to be coming from the center of the vehicle so I do suspect that intermediate shaft bearing may be the cause but I see very little information on it in the forums.

Thank you for any insight or advice you can provide.
 

·
Registered
2007 Kia Sedona, 2000 Nissan Maxima
Joined
·
17 Posts
I need to do this as well and currently looking for a solution. I have the same symptoms, vibration around 35-45mph, when I let off the accelerator it goes away. I lifted and got under the van to inspect everything, grabbed the center/intermediate shaft and noticed some play in the carrier bearing at the bracket. I also noticed my cv-axles may be shot. Best price I could find for that intermediate shaft online was $229, everything else seems to be used.
 
1 - 3 of 3 Posts
Top