Kia Forum banner

1 - 20 of 93 Posts

·
Registered
2017 KIA Sorento SXL V6 AWD
Joined
·
31 Posts
Discussion Starter #1
We noticed yesterday that the full-screen map display in our 2017 Sorento SXL wasn't showing the time. Switching to the home screen, the time shows as '--:--'. In Setup->Clock, GPS Time is turned on; all the other controls are greyed-out. Turning GPS Time off and on doesn't change anything, and there doesn't seem to be any way to manually set the time, even with GTP Time off (because what I think is the control to get to the setting screen is in-op). The rest of the GPS functions seem to be working properly -- the car knows where it is, and tracks properly on the map.

Looking at the GPS status from (if I remember correctly) the Setup screen, it shows lots of satellites in range, but the time shows as sometime in 1969, which I think is the beginning of the time epoch, and means that the clock has a zero value.

Anyone seen this? Know how to recover? We find we really miss having the time display.
 

·
Registered
2019 Sorento SX L (FWD)
Joined
·
285 Posts
GPS just in the last few days hit a y-2k type problem (count of weeks overflow) that affects older/not updated units.
 

·
Registered
2016 Sorento SXL
Joined
·
899 Posts
Hard to believe since earlier and later models (nor even any other 2017 heard here) aren't having this issue, but it sounds like you hit a code regression in your particular device. Your symptoms could indicate a rollover failure on 6 April. That one device 'out of the middle' of so many would experience this is pretty amazing.

In your case, it might be of interest to completely kill power to the head unit (and hence, the GPS) for a period of some minutes, and force it to re-awaken and reacquire the almanac. Can take anywhere from 10-20 minutes in a 'clear' sky. Will be interesting to see if re-acquisition of the ephemeris data has any impact on the date/time calculation. It may be that the rollover itself failed, but that the firmware will correct that when it sees a time beyond that of the rollover moment.

Just to be clear, the device IS correctly obtaining a fix for your position, yes?
 

·
Registered
2017 KIA Sorento SXL V6 AWD
Joined
·
31 Posts
Discussion Starter #4 (Edited)
Hard to believe since earlier and later models (nor even any other 2017 heard here) aren't having this issue, but it sounds like you hit a code regression in your particular device. Your symptoms could indicate a rollover failure on 6 April. That one device 'out of the middle' of so many would experience this is pretty amazing.

In your case, it might be of interest to completely kill power to the head unit (and hence, the GPS) for a period of some minutes, and force it to re-awaken and reacquire the almanac. Can take anywhere from 10-20 minutes in a 'clear' sky. Will be interesting to see if re-acquisition of the ephemeris data has any impact on the date/time calculation. It may be that the rollover itself failed, but that the firmware will correct that when it sees a time beyond that of the rollover moment.

Just to be clear, the device IS correctly obtaining a fix for your position, yes?
Yes; the device knows where the vehicle is, and tracks properly on the map. The only thing missing is the time.

So is your suggestion to just disconnect the battery for, say, half an hour, and then re-connect? Or better to pull an appropriate fuse?

Any issues from disconnecting the battery for a while?
 

·
Registered
2016 Sorento SXL
Joined
·
899 Posts
I'd go ahead and pull the appropriate fuse rather than the battery cable. That will avoid resetting anything else that depends upon unswitched power. I don't know how long certain items (e.g., power seat positions) are held when there's no battery available at all.

Only pull the one for "Multimedia". It's a 15A fuse.
 

Attachments

·
Registered
2017 KIA Sorento SXL V6 AWD
Joined
·
31 Posts
Discussion Starter #6
I'd go ahead and pull the appropriate fuse rather than the battery cable. That will avoid resetting anything else that depends upon unswitched power. I don't know how long certain items (e.g., power seat positions) are held when there's no battery available at all.

Only pull the one for "Multimedia". It's a 15A fuse.
I pulled the fuse (fortunately, I'd read the owner's manual and knew there was a fuse puller under the hood -- those things are tiny). I let it sit for a few minutes, so the electrons had a chance to run out :D, put the fuse back, and voila, the clock was there again. The GPS hadn't lost the satellite info, either.

Thanks very much for your help!

P.S. Man, this car has a lot of fuses... I was glad for the chart on the cover (and in the manual).
 

·
Registered
2016 Sorento SXL
Joined
·
899 Posts
Good to hear you're back 'in sync'. Odd that the firmware seemed to glitch at the transition of the rollover, but can handle the rollover after the fact.
 

·
Registered
Optima hybrid 2017
Joined
·
1 Posts
Just noticed, today, the same problem with my ‘17 Optima hybrid! It actually showed 9 something am, while it was 5:45 pm. Set it manually back to the correct time. Made a stop and when I returned I had the same display you mentioned —:—. Also, the manual setting option was no longer available.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
9,769 Posts
Just noticed, today, the same problem with my ‘17 Optima hybrid! It actually showed 9 something am, while it was 5:45 pm. Set it manually back to the correct time. Made a stop and when I returned I had the same display you mentioned —:—. Also, the manual setting option was no longer available.
Please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.


eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature
 

·
Registered
Joined
·
1 Posts
So.... Same exact situation here. At first the date said February 6 and 8:00 AM when it was actually 6:00 PM. And then when we went into a store and came back out there was no longer any date nor time and the settings were great out so I couldn’t make any changes. Help?

I am slightly frustrated as I was just at the dealership for them to fix two recalls that were sitting on my car yesterday. I left there and everything seemed fine and then today this happens. 😢



Just noticed, today, the same problem with my ‘17 Optima hybrid! It actually showed 9 something am, while it was 5:45 pm. Set it manually back to the correct time. Made a stop and when I returned I had the same display you mentioned —:—. Also, the manual setting option was no longer available.
 

·
Registered
Joined
·
1 Posts
We noticed yesterday that the full-screen map display in our 2017 Sorento SXL wasn't showing the time. Switching to the home screen, the time shows as '--:--'. In Setup->Clock, GPS Time is turned on; all the other controls are greyed-out. Turning GPS Time off and on doesn't change anything, and there doesn't seem to be any way to manually set the time, even with GTP Time off (because what I think is the control to get to the setting screen is in-op). The rest of the GPS functions seem to be working properly -- the car knows where it is, and tracks properly on the map.

Looking at the GPS status from (if I remember correctly) the Setup screen, it shows lots of satellites in range, but the time shows as sometime in 1969, which I think is the beginning of the time epoch, and means that the clock has a zero value.

Anyone seen this? Know how to recover? We find we really miss having the time display.
Hi, new here! So this just happened to me last night. The same exact thing. Everything was perfectly fine, then after sitting for a while I started the car and it was February 6, 6:30 am. We stopped again, and then completely gone. Did this same thing happen again ? I see this was posted 4 months ago. I have a 2017 soul. Great timing though, going to the dealership in a few hours for an oil change. I love my car but I don’t understand half of what’s in it lol!
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
9,769 Posts
Hi, new here! So this just happened to me last night. The same exact thing. Everything was perfectly fine, then after sitting for a while I started the car and it was February 6, 6:30 am. We stopped again, and then completely gone. Did this same thing happen again ? I see this was posted 4 months ago. I have a 2017 soul. Great timing though, going to the dealership in a few hours for an oil change. I love my car but I don’t understand half of what’s in it lol!
Please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.


eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature
 

·
Registered
KIA Sorento EX Limited 2016
Joined
·
2 Posts
Same thing happened to our 2016 Sorento yesterday. I pulled out the fuse for the media center as shown in the diagram. I used a needle nose pliers to pull the fuse. I waited a few seconds until plugging it back in. Also, I ejected the SD card which causes the media center to reboot. It took me a few tries for the clock to sync again.
 

·
Registered
2016 Sorento SXL
Joined
·
899 Posts
Ditto this problem here yesterday.
I shut down the GPS Time, manually set the clock, returned to "Home", then went back and reset to GPS time again. It seemed to be holding the correct time. This morning, time shows as - - : - - so I guess I'll have to take my own advice regarding pulling the fuse. Rats.
 

·
Registered
2016 Sorento SXL
Joined
·
21 Posts
Seems to be a wider issue, I just had the same issue today. Going to try the fuse method to reset.
Edit: Pulling the fuse worked for me!
Also as an FYI for those that don't know, there is a fuse puller located in the fuse box in the engine bay.
 

·
Registered
Joined
·
1 Posts
My clock is not displaying at all, the entire Clock menu is greyed out and I can not make any changes.

It started yesterday when it was displaying the wrong Day and Time, and now today nothing at all..
Canadian 2016 Kia Sorrento
San Diego, California
112266
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
9,769 Posts
My clock is not displaying at all, the entire Clock menu is greyed out and I can not make any changes.

It started yesterday when it was displaying the wrong Day and Time, and now today nothing at all..m
Please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.


eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature
 

·
Registered
Joined
·
1 Posts
Yep, this happened to our 2017 Sedona today as well. I'm wondering if there was some kind of GPS update that went out? I tried pulling the media fuse for 20/30 mins but no joy. It still reads --/--

Did it work for anyone else?
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
9,769 Posts
Seems to be a wider issue, I just had the same issue today. Going to try the fuse method to reset.
Yep, this happened to our 2017 Sedona today as well. I'm wondering if there was some kind of GPS update that went out? I tried pulling the media fuse for 20/30 mins but no joy. It still reads --/--

Did it work for anyone else?
Please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.


eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature
 

·
Registered
2016 Sorento SXL
Joined
·
21 Posts
Check this post
 
1 - 20 of 93 Posts
Top