Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
This is my first post on the forums, If this is on the wrong sub forum please let me know.

I have a 2002 Sedona EX. The front A/C heat and even just air does not blow when you turn the switch on. Should I check a fuse? Or does it sound like a blower motor?

The rear air/a/c and heat works fine, but I just found the lines on the right hand side rusted out. I was told that's the rear coolant lines for the heat? Can you still drive it with the lines rusted out? Or will it empty the anti freeze from the whole car? I was told it will keep pumping anti freeze back there and with the hole it will end up draining the system?

This is our first KIA, and so far We have yet to be able to drive it. Still have to flush the transmission because the fluids are black and smell burnt. Any and all help anyone can give would be great.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I pulled the blower motor and tested it and it spins and works just fine. I'm thinking it's the resonator, if it's dead completely will that keep the motor from working at all? Also the A/C button does does not light up green when you push it in? Could this be a relay? I checked all the fuses and they all look fine??
 

·
Registered
Joined
·
13 Posts
It sounds like it is the heater control switch on the dash. I had the same problem and had to change out the switch. Try pushing in on the switch and see if it will make the fan work.

If the rear heater lines are rusted and leaking it will drain your antifreeze if you do run it when leaking.
 
1 - 3 of 3 Posts
Top