Kia Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello all. Just joined.... I was hoping I could get some help here. This is the issue:

I have an '08 Sorento - EX 2.5 diesel RHD - that I only recently got back after some major body work.
While it can be driven, the vehicle has some issues: a faulty door open/closed switch, one door is unpowered, air-con fan inop. HOWEVER, what I want to deal with is a loose terminal I found on the engine (pic attached). It's bolted onto the engine, but the other end isn't connected to anything. It's just floating. Does anyone have an idea where it goes to? I tried looking to see if there was a loose bolt on the chassis somewhere in the vicinity, but no luck.
Motor vehicle Automotive tire Electrical wiring Gas Cable
 

· Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Yes.... I thought that the pics may still be obscure.
As far as I could discern visually, the wire seems to be only attached to the block. I did a resistance check though and it tested as directly connected to the engine. I'll try to check for what you described. I believe I saw it earlier on in my first checks and don't think there was a nut on the stud. Time permitting, I'll check into it tomorrow and fill you in.
Thank you.

Looked at your other photos sent via PM, but not entirely clear on the "look down" between power steering resv. and airbox. The angle is obscured by the reservoir. Anyway, I zoomed in as much as I could and I believe that loose wire should attach to the inboard of the 2 studs there - if there is nothing there now. I cannot tell if anything is already there, or even if there is a nut missing off that stud. Just be sure that the other end is only attached to the engine block as you stated.
 

· Registered
Joined
·
7 Posts
Discussion Starter · #5 ·

· Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
SO.... I could not find the dang stud! ...but on the brighter side I replaced the fan and the A/C's working again.
In my tropical heat that's a blessing esp so as my other ride - a Y12 AD Wagon (or Van some call it) - has suddenly gotten ill and is down so no choice but use the Sorento as is 🤞 ....until I get the Wagon up and running again.
Kind of under the weather still. When it rains, it pours! 😂
 

· Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
gee6 - Now we're talking! Thank you for taking the time to send those pics! I really appreciate that. I was thinking if there may be an option. Will have to do some little cleaning and both you and leo42 indicated would be required.
Right now into and under the Y12 removing the alternator. 😅
 
1 - 5 of 5 Posts
Top