Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
I was driving my kia down the road of course and i got hard to drive like it was slowing down then it started shaking my engine light flashed on and off then it cut off again! Yes I got it back home but I want to know what it is im taking it to my mechanic shop in the morning. Any ideas Oh yea put a new battery in its not completely on the terminal I didn't do that tho is that what it is?
 

·
Registered
Joined
·
2,217 Posts
I was driving my kia down the road of course and i got hard to drive like it was slowing down then it started shaking my engine light flashed on and off then it cut off again! Yes I got it back home but I want to know what it is im taking it to my mechanic shop in the morning. Any ideas Oh yea put a new battery in its not completely on the terminal I didn't do that tho is that what it is?
Greetings,

It could very well be low voltage causing the issue: I would get back to that auto parts store and re-confirm the battery group -> the battery they sold you - it doesn't sound like the right size (group) battery,

and (if it was me) I'd check voltage at the battery, and at the passenger cabin fuse box, w/ a multimeter when the issue is happening,

and hookup a live data scanner to the OBDII port to see (what) values the ECM is reading from the various sensors (air/coolant temp, MAF, O2 sensors, etc.

--
But would get that battery issue corrected, in any case, by installing the (correct) sized battery..

Regards,
GottaCruise
 
1 - 2 of 2 Posts
Top