Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2006 Sedona. When I turned the van on today, I could not get the a/c to work. The fan doesn't blow or anything. The lights that would indicate the a/c is on (in the front, and the control for the rear) does not light up. Any idea of what the problem could be? Unfortunately for us, it is Sunday and the dealership is closed until tomorrow morning. :( Everything worked perfectly normal yesterday.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
After I did a lot of searching and reading on this site, I finally convinced my husband to unhook the battery and hook it back up to see if it reset and started working again. It did. Now, does this mean that there is an issue that needs to be repaired, or was this just something that could happen from time to time and unhooking the battery is all it needs?

I'd really appreciate some input! And thanks!
 

·
Registered
1999 Kia Sephia, 2016 Kia Optima SXL, 2019 Kia Soul Plus
Joined
·
1,110 Posts
After I did a lot of searching and reading on this site, I finally convinced my husband to unhook the battery and hook it back up to see if it reset and started working again. It did. Now, does this mean that there is an issue that needs to be repaired, or was this just something that could happen from time to time and unhooking the battery is all it needs?

I'd really appreciate some input! And thanks!
There is a Kia technical service bulletin regarding this issue. The A/C control head has a logic issue and locks up. Kia suggests unhooking the battery or the control head. Either way usually fixes it. I haven't seen any repeat visits for the same issue from past customers.
 
1 - 3 of 3 Posts
Top