Kia Forum banner

1 - 3 of 3 Posts

·
Registered
2011 Kia Sorento EX, 3.5L V6
Joined
·
5 Posts
Discussion Starter #1
113621

This is a 2011 Sorento EX 3.5L. the photo here is the right bank (closest to the windshield)

Does anyone know what the extra plug I've circled is for? I'm reassembling after a timing chain, cvvt, and camshaft swap, and I cannot find anything that seems like it would plug into this wire.

I have a Haynes manual and an Alldata diy subscription and this wire does not appear on the diagrams in either. The inside of the plug is filthy, and I took tons of photos during disassembly. In all of those it is just sitting there on top of the right bank valve cover unplugged. That leads me to believe that it hasn't been plugged in for years, or maybe ever?

I've since reinstalled the plenum and connected all engine wiring and there were no other unused connections. I'm hesitant to start the engine because I'm worried I've overlooked something.

Any help about this wire would be much appreciated.

Thanks
 

·
Registered
KIA Sorento 2012 3.5 v6
Joined
·
2 Posts
View attachment 113621
This is a 2011 Sorento EX 3.5L. the photo here is the right bank (closest to the windshield)

Does anyone know what the extra plug I've circled is for? I'm reassembling after a timing chain, cvvt, and camshaft swap, and I cannot find anything that seems like it would plug into this wire.

I have a Haynes manual and an Alldata diy subscription and this wire does not appear on the diagrams in either. The inside of the plug is filthy, and I took tons of photos during disassembly. In all of those it is just sitting there on top of the right bank valve cover unplugged. That leads me to believe that it hasn't been plugged in for years, or maybe ever?

I've since reinstalled the plenum and connected all engine wiring and there were no other unused connections. I'm hesitant to start the engine because I'm worried I've overlooked something.

Any help about this wire would be much appreciated.

Thanks
I'm here for the exact same reasons
 

·
Registered
2011 Kia Sorento EX, 3.5L V6
Joined
·
5 Posts
Discussion Starter #3
I'm here for the exact same reasons
I never got an answer. It remains a mystery. For what it is worth I left it unconnected (and I believe it always was unconnected) and I've put about 250 miles on it since then with no noticeable problems, no check engine light, nothing.
 
1 - 3 of 3 Posts
Top