Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi. I'm a proud owner of a 2006 Rio and I haven't got any problems with my car 'till yesterday. I wanted to change the lightbulb in the trunklight, but when I finished: the central locking stopped reacting to the pilot, the clock inside stopped working and the dials on the dashboard begun to act weirdly. The engine works like a charm, but when I stop the engine and take the key out of the ignition, revmeter, temp meter and the fuel meter stay in the same place they were with engine on... Then when I start the engine again they fall to 0 (the meters) and then go back up... I've searched the internet and I found out that maybe the ETACS unit is malfunctioning, but is there any way to prove it ? Does anyone had a problem like this ?
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,923 Posts
Not seen any RIOs with ETACS/BCM problems...I have seen them in around 5~10 Spectras (usually 2005~2007).

Another reason NOT to think ETACS is the clock and the gauges are NOT controlled by the ETACS/BCM...

I would suggest you checking ALL the fuses (with a multimeter set to continuity)...Remove the fuse...check and reinstall...

In my Spectra the Dash lights are fused through the right rear tail light fuse..
So a very strange relationship with problems seemingly not related CAN be caused by a very strange fuse blown...

I believe you would be throwing away money replacing the ETACS.
Dave
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
It turns out that some of the connections in the electric circut were burned out. Thats why some of the components didnt get any electricity. Problem is solved, ETACS wasn't replaced and it works just fine. Thanks for your reply :)
 
1 - 3 of 3 Posts
Top